[BETA] Blynk Library v0.5.0

The next Blynk Library release 0.5.0 is available for BETA testing.

It includes some major changes in the internal logic, which can improve stability a lot, as well as make it easier to use.
From the first glance, it can be hard to spot the difference, but in fact it enables you to run any number of Blynk commands (virtualWrite(), setProperty(), etc.) in a row!

Among other changes (we’ll announce the full list with the 0.5.0 release), this also includes:

  • ESP32
    • Bluetooth LE initial support + example
    • SSL support + example
    • App Export example for ESP32 (with WiFi credentials provisioning)
  • ESP8266
    • SSL improvement (more stable, but still not perfect due to a bug in ESP Core)
    • ESP8266 now checks certificate chain (previously fingerprint was used)
    • Shield mode (AT commands) stability improvements
  • Realtek RTL8710 / Ameba support
  • Arduino UNO WiFi support
  • WizFi310 support
  • Better ARM mbed support
  • Library is refactored, easier to run on 3rd party hardware, etc.

As this update contains many (possibly breaking) changes, we’re doing this beta release to get early feedbacks from our bravest community members :wink:
Please check out the latest library, and give your feedback in this thread (be sure to specify the hardware you’re using).
The update is available in master branch: https://github.com/blynkkk/blynk-library/archive/master.zip



@vshymanskyy regarding running commands in a row and the SSL bug. They are predominately Arduino ESP8266 Core 2.3.0 bugs. Are you still running 2.3.0 and if not is the SSL issue still a problem in the vastly improved 2.4.0-rc2 core?

Link is referring on ver. 2.3.0. So stability might be perfect with 2.4.0rc2 :slight_smile:

Regardless of ESP Core version currently. 2.4.0-RC2 is affected as well.

Few notes on ESP32 BLE support:

1 Like

Any feedbacks?

I am not brave enough :stuck_out_tongue_winking_eye:

Actually, I have thought about it, but I didn’t have the setup to run a separate (accessible) IDE with this library, and was unwilling to take chances with what I have working already…

But now I think I can attempt running an IDE on my RPi3 and perhaps then test some BLE connections with my ESP32… will give it a go…

Hello, I have an ESP32 module and willing to test/experiment for you. But I will need some guidance installing the correct libraries for the ESP32. I have already tried out a few but did not manage to get much results though… Let me know if you want me to test !

Kind Regards,


Be prepared that this heads into somewhat “advanced” levels… the idea is for us testers to offer the developers support (as we trip over all the bugs :wink: ), not the other way around.

Installing the Arduino-ESP32 CORE is not a Blynk specific thing… here is the direction for that from espressif. But you will need to ask over on their forums/support for any instalation issues you encounter.

And installing Blynk Library 0.5.0 is absolutely no different than any other version, except where you get it from… that link is in the first post above.

1 Like

I assume installing the 0.5 Beta library is the same as any other ? Sketch - Include Library - Add ZIP File ?

I did this with the downloaded ZIP File blynk-library-master.ZIP from the link you provided. Restarted Arduino. In Manage Library it still shows 0.4.10 ? (See screenshot attached)

Managed to istall everything including the arduino-esp32-master. Selected one of the Blynk master examples and compiled (my board is DOIT ESP32 Dev Kit 1.0 but run in to the following error :

blynk-library-master\src/BlynkSimpleEsp32_BLE.h:53:19: error: ‘createServer’ is not a member of ‘BLEDevice’

     pServer = BLEDevice::createServer();

Always recommended to uninstall old library before cleanly installing new one… especially a Beta one.

Done and compilation is succesful now ! :slight_smile: … Created Blynk App and got auth code.

Sktch used : ESP32BLE …

Not sure what to do now ? When I strat the App (BLE or BLUETOOTH) get “not connected” …

Did you follow the normal BLE connection methods in the BLE widget in your project? Open Widget, connect to device, then start project.

I believe so … Faslhing the device went OK, no errors. When the device boots I get following :
flash read err, 1000
ets_main.c 371
ets Jun 8 2016 00:22:57

configsip: 0, SPIWP:0xee
mode:DIO, clock div:1
entry 0x40078a9c

I do not get the “Waiting for connections…” message …

Google this error for more things to look at…

You may not have the sketch properly installed?? You can try to enable DEBUG mode and see if that shows any info in the Serial Monitor.

However I would caution you… AFAIK none of this is touching on the BETA library yet, so if you are already running into issues, you might want to step back and just work with the stable library and with non-BLE related configurations for now

You can build for WiFi first, to see if Serial Monitor shows the right version. But,.if BLE Esp32 example compiles fine - it’s 0.5.0 for sure.

Don’t bother with the regular zip method, do it all manually as per the docs.

Meanwhile I succesfully compiled, no errors in debug window, the sketch and uploaded it in my ESP32. In the Blynk App I have added the BLE (Beta) widget. When I click on “Connect BLE device” I ghet the “Select BLE device” but none is shown ? The Device in Blynk App is as follows :

ESP32 DEV Board
Connecion Type : BLE

What am I still doing wrong ?

Thanks !