BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

SSL not authorized

I have checked this forum for similar symptoms. Either nobody has this issue or it is trivial. Either way, I’m hoping for a push in the right direction. I am new to blynk. I am at the very first step of getting an RPi 2B communicating with my phone (blynk app). Installed all requisite on the Pi and am trying the first example that uses 2 virtual pins and failing:

Running “blynk-client [token]”
[Blynk splash]
OnOff mode
Connecting to: blynk-cloud.com 443
SSL authorization…
SSL not authorized
… loops
I did verify that the server.crt file content was the same as that contained on github in blynkcloud_pem.h (blynk-library/blynkcloud_pem.h at master · blynkkk/blynk-library · GitHub).
Any tips would be appreciated.

You should read this…

Then switch to a non-SSL connection until the issue is resolved.

Pete.

Thanks PeteKnight. Changing to TcpClient moved the ball forward :-).

Can you please share what you did exactly? I’m still trying to resolve connection problems that I start experiencing today. Thank you in advance.

The “blynk-library” files installed in /usr/local/lib/node_modules/blynk-library assumes SSL connection in a file called blynk.js. I modified it:

307c307,308

 this.conn = new bl_node.SslClient(options);

 //this.conn = new bl_node.SslClient(options);
 this.conn = new bl_node.TcpClient(options);

That’s all.

Thank you very much!

I guess this doesn’t help on connecting esp8266 (Arduino lib) to blynk-cloud.com.

That’s much simpler.

Change from the BlynkSimpleEsp8266_SSL.h to BlynkSimpleEsp8266.h and if you’re specifying a port in your Blynk.begin command make sure you change that to 8080.

Pete.

I have been facing the same issue with SSL and tried to do this but I am not able to edit the blynk.js file. It shows an access denied message. I’m using rasbperrypi. Any ideas as to how to fix it?

Who is the owner of this file?
Have you tried editing via the command line using the sudo modifier at the beginning of the command?

Pete.

yes, I tried and then I was able to edit the file. I however am still getting the SSL error

. Any tips as to what I should be doing? I downloaded the library as per the instructions on the blynk page for raspberry pi setup.

When I try to import the library in python it gives an error message “No module name blynklib”. Is this related to the SSL issue?

It’s far better if you take screenshots rather than posting photos of your screen.

Pete.

Inked2021-05-01-132847_656x416_scrot_LI

This is after changing SSL to TCP in the blynk.js file. Still seem to get the error.

Take a look at this post, which identifies combinations that work. You do not have to modify the system supplied blynk.js. You can modify your own code & use options=…