Login Time Out , Finding Alternative in Windows to Find the Problem

Thanks to Friends in this great community to help in

my step1:

A Mysteries about esp-01 (esp small shield) (Students Nightmare)

and my step2:

Defective found in official blynk help… very urgent and important

i Thanks perosonlay every person who replay me

my step3 : maybe its repeated but idea is different…

for who not know my pervois steps:
its arduino uno + esp8266 as module (wifi for arduino)
i flash it with 1.54 version
ready for blynking

i want just hand shake with blynk server and turn on and off pin 13 (led)
i got “Login Time Out”

code i used

Note: i put + for sensitive information

#define BLYNK_PRINT Serial

#include <ESP8266_Lib.h>
#include <BlynkSimpleShieldEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth = “+++++”;

// Your WiFi credentials.
// Set password to “” for open networks.
char ssid = “+++++*”;
char pass = “+++++”;

// Hardware Serial on Mega, Leonardo, Micro…
//#define EspSerial Serial1

// or Software Serial on Uno, Nano…
#include <SoftwareSerial.h>
SoftwareSerial EspSerial(3, 2); // RX of esp, TX of esp

// i know in orginal is EspSerial(2,3) but i usuly go and back from softSerial to RealSerial
// and i not want swap wire every time

// Your ESP8266 baud rate:
#define ESP8266_BAUD 9600

ESP8266 wifi(&EspSerial);

void setup()
// Debug console
// Serial.println(“@CheckPoint=01”);

// Set ESP8266 baud rate

Blynk.begin(auth, wifi, ssid, pass);

void loop()
// delay(1);

Serial Monitor :

___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v0.5.4 on Arduino Uno

[2601] Connecting to +++++
[5809] AT version: 11 2016 18:09:56)
SDK version:1.5.4(baaeaebb)
Ai-Thinker Technology Co. Ltd.
Jun 13 2016 11:29:20
[9111] +CIFSR:STAIP,“+++++”
[9119] Connected to WiFi
[22405] Login timeout
[36438] Login timeout

So i dont Reach Check Point 05 … mean its stuck at

Blynk.begin(auth, wifi, ssid, pass);

There A lot of reason for that
**what i need a tool **
or exe file to connect to Blynk as its arduino code
and using laptop wireless to find is there firewall or not reaching to blynk port
or maybe in my token
this will answered if i used that tool

Thanks a lot

Update : …
Finding This Command


i got new print under login timeout

<[02|00|01|00] ++++++

This version of the Blynk library is extremely outdated. I’d recommend that you update to V0.6.1 before going any further.

And as I said before…

If you’d have spent $4 on a NodeMCU you would have been up and running within minutes of it arriving, rather than pouring hours into this Arduino/ESP-01 combination. I understand your comment about having lots of existing Arduino code, but it really is very simple to port across to the NodeMCU (certainly much easier than the battles you’ve had with this setup).

As far as wanting to try to understand the debug messages, You should take a look at this topic (once you’re running the latest version of the library)…


A lot of thank for replay again … i very thankful

did you mean V0.6.1 is 2.6.1 ?

very sorry i confused …

you mean Bylnk Library ,… i will try again

No, that’s not the Blynk library, that’s the ESP Core - which you do not need.
The ESP core is only needed when you upload sketched to an ESP8266 based device. If you do that then you’ll overwrite the AT firmware and have to re-load it using the ESP Tool - which I’m sure you don’t want to have to do again.


but i think it’s used for …

#include <ESP8266_Lib.h>


#include <BlynkSimpleShieldEsp8266.h>

or both

You are incorrect.


you right …

i remebr i have problem with

#include <ESP8266_Lib.h>

but using second method


2. Install Blynk as ZIP file in Arduino IDE

Blynk library is available as a downloadable ZIP. Starting with Arduino IDE version 1.0.5, you can install 3rd party libraries in the IDE.

Download Blynk Library by clicking the button:

Download Blynk Library

:point_up:Do not unzip the downloaded library, leave it as is.

  1. In the Arduino IDE, navigate to Sketch > Include Library > Add .ZIP Library . At the top of the drop down list, select the option to "Add .ZIP Library’'.
  2. Return to the Sketch > Include Library menu. menu. You should now see the library at the bottom of the drop-down menu. It is ready to be used in your sketch. The zip file will have been expanded in the libraries folder in your Arduino sketches directory.

The Library will be available to use in sketches, but with older IDE versions examples for the library will not be exposed in the File > Examples until after the IDE has restarted.

didn’t work even its official blynk help

so i extract every folder from zip file and put them in arduino inside folder
with same folder names

i feel i do " a turn" from the plan
but error of not finding “ESP8266_Lib.h” is no more

is this method maybe the problem ?

As you already have an old version of the library installed then the simplest method is via Method 1

If you had an issue installing the old library with Method 2 then this is probably because the instructions are for a later version of the library, as you can see from the screenshots.


Thanks for replay i updated and same result but debug code change

___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v0.6.1 on Arduino Uno

[2601] Connecting to wwwwwifiname
[5821] AT version: 11 2016 18:09:56)
SDK version:1.5.4(baaeaebb)
Ai-Thinker Technology Co. Ltd.
Jun 13 2016 11:29:20
[9121] +CIFSR:STAIP,“iiiiiiiiiiiiip of esp”
+CIFSR:STAMAC,“mmmmmac of esp”
[9129] Connected to WiFi
[19303] <[1D|00|01|00] tttttttttttttttttttoken code
[22432] Login timeout
[33332] <[1D|00|01|00] tttttttttttttttttttoken code
[36452] Login timeout

now debug code refer to <[1D|00|01|00]

but printing my token in place of “tttttttoken code” beside debug code
feel me it’s token problem

if you wnat to test your token then paste this in the address bar of your web browser.


If it’s the correct token then you’ll get a JSON string with project information. if not then you’ll gert an Invalid Auth Token message.

You could try changing this line…

to this…

Blynk.begin(auth, wifi, ssid, pass, "blynk-cloud.com", 8080);

to force the use of port 8080 in case your ISP is blocking port 80.


that what exactly searching…

after doing the test link try create new device with new token still get this in test link



when i just writing address without any more info like below


in address bar

its redirect me


then another redirect to


see it seem


About test link … can you give me a successful page
who shuod be in good status
maybe its show for all people like that

so after this result … if i used esp32 or esp12e i will get same problem
because no linking between me and my token …is that right ?

Update :



Update : (Yahooooo…)

This Fixed it … i used button to turn led 13 on and off

step 3 : is finish …

Thanks a lot


i just change test for add “:8080” sitename with port
but result same
seem test link not working at all
so it’s not dependable


i wonder if another test link or test method for future tests

Okay, I’m glad that you have it working with port 8080

Attempts to browse to blynk-cloud.com will always redirect to Blynk.io and adding a port number to this wont make any difference.
An API call with blynk-cloud.com/ followed by a valid auth code and /project will return the JSON for your project and yes, this will always show as an insecure connection (the security comes from the auth code).

You’ve added http:// to the front of the URL, which shouldn’t be an issue, but you’ve obliterated too much for me to tell if the `/project’ on the end is correct or not.

The HTTP API is documented here:


1 Like

Thanks For Replay

i figure other way to test using information form this web site maybe
it’s will useful for reader

exactly i also find this web site
form link we can useful for test

lets take possible problity

Note : “TOKEN” Replace with your token

Tester Link :


1 - can’t access to blynk server

i change “cloud” with “clous” to see how people see page when they can’t
access the server , because in my case i can assess to web site


2 - can access to server but invalid token


3 - Token alright but pin not Right


4 - Token alright and pin alright

or any thing that not show “Wrong pin format”

Then if we in Probity (4)

and your blynk version v0.6.x and above … as you mention early

and still problem it’s very high ratio it’s

Thanks a lot… and this Step Over and do what they want from it

  • Defeat Login timeout
  • Browser Test Approach “windows and other os…” to Test the Link

if lable can edit … i will change it to

login timeout , Finding Alternative way to test and finding the problem

Happy Blyking...

Unfortunately, what you’ve written in your last post makes no sense to me at all. Probably much of it is ‘lost in translation’.

Are you asking a question in there somewhere?

Should I mark this topic as “Solved”?


i just give road map to whom got this problem in future to get useful from it as we figure out by
“trail and error”

no i am celebrating :grinning:

yes … thanks …