BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

[SOLVED] Problem with push notifications on Android

Hoping someone can help. Push notifications were working correctly until I did an update to the Blynk app on Android. Now the notifications only appear when I am in the app. If I go out of the app the push notifications do not occur.
I have reprogrammed the Arduino project (using an Arduino and Ethernet shield).
I have restarted my phone.
I have uninstalled and then reinstalled the Blynk app.

Does anyone have any suggestions to try to get this working again?

Thanks

Did you see new settings within notification widget? Maybe you need to set “High priority” notifications?

Thanks for the reply. Even though it used to work correctly before the high priority setting on the widget, I did try it and it did not make any difference. It is on high priority now and notifications are not coming through :sad:

What device do you have and which app version?

We made update for not showing notification when user makes logout from the app. Are your ‘go outs’ just setting app for background and exit, or logouts?

1 Like

I am using an Arduino Uno R3 with Ethernet Shield - this setup used to work correctly. My phone is a Samsung Galaxy Note 3 with the latest version of the app - reinstalled the latest app this morning.

Thanks for the reply. I am definitely not logging out from the app - to exit the app I click the home button on the phone to go to the menu - I assume that the app is running in the background? The app also does not have background data restricted - however, it does not even work on my WiFi connection when I am on the home screen - notifications only work when I am in the app.

App receives notifications via google cloud messaging (from google servers), so it’s not the issue of app working/not working in the background. I’ll check what we have changed for causing such issues.

Also because of users requests we made app not working in the background, due to battery drain issues, so it would not work in background on any time of connection.

@BlynkAndroidDev Is it possible to access the previous versions of the Blynk app to get back to the one that was working correctly?

you could try to use this build https://www.dropbox.com/s/yc7vmzkhvm4fdu4/blynk_app-release-rc12-jan14-2.apk?dl=0

seems i’ve found the cause of this bug with notifications, maybe we’ll soon prepare a new build with fixes

Thanks for the link and for looking into a fix for this so quickly.

Any news? I have the same issue. I receive notification only if I’m on the app. The alarm system I created is unsable :cry:

please use previous build, with next release (soon will be released) this issue would be fixed

@BlynkAndroidDev I tried various previous builds. Only with Blynk 1.0 RC11 I receive notifications in all conditions; with RC12 and RC13 I receive notifications only if I’m on the app.

Agree with @mimmo13 Tried the app linked to above and also doesn’t work. Hopefully will be fixed soon in the new release.

Guys, issue is fixed. Please check latest build.

1 Like

Thank you. Tested and all is well :grinning:

Thank you!!! You are the best!

1 Like

@BlynkAndroidDev
Good day. With yesterday’s update of the Blynk app my notifications are again no longer working. Please could you provide a link to the previous version of Blynk so that I may downgrade back to it.
Thanks

Hi, i’ve rechecked them with my device - seem’s it’s ok. Are you using local or blynk server? If local - try to update it to latest version