[SOLVED] "Failed to disable echo" PROBLEM


I still have connection problems:

"Failed to disable echo" [UPD: this will most probably be reported as “ESP is not responding” now]

but I can not understand why …

firmware esp2866 is:


AT version: (8 Aug 2015 14:45:58)

SDK Version: 1.3.0

To-Thinker Technology Co., Ltd.

Build: Sep 11, 2015 11:48:04


so I think this is not the problem as the required firmware is the sdk 1.00 v0.22;

I also powered externally esp2866 to avoid power problems;

pins esp2866 TX and RX are respectively connected to pin 3 and pin 2 of the Arduino;

the code used is:


//define BLYNK_DEBUG

define BLYNK_PRINT Serial // Comment this out to disable prints and save space

include ESP8266_SoftSer.h>

include BlynkSimpleShieldEsp8266_SoftSer.h>

// Set ESP8266 Serial object

include <SoftwareSerial.h>

SoftwareSerial EspSerial(2, 3); // RX, TX

ESP8266 wifi(EspSerial);

// You should get Auth Token in the Blynk App.

// Go to the Project Settings (nut icon).

char auth[] = "YourAuthToken";

void setup()


// Set console baud rate



// Set ESP8266 baud rate

// 9600 is recommended for Software Serial



Blynk.begin(auth, wifi, "ssid", "pass");


void loop()




I would be glad if someone could help me … I do not know what to do …


Actually you need exactly version 0.22, it may not work with further versions.
We will check other libraries for compatibility, maybe it will fix the issue!

I fixed the echo problem with a 100ųf between 3.3v an ground using the arduinos power supply

Thank you very much,
I’ve flashed the 0.22 version and now everything works fine!

Has this changed from early days? I have an existing project that refuses to connect anymore.

I had the same problem… try to re-flash the firmware on the ESP with Nodemcu, it worked for me

I’m swimming in browser tabs at the moment… would you be so kind as to post me a link to the binary for either the proper Expressif firmware or nodeMCU binary that I can flash? I feel like I am reinventing the wheel just to get my project up and running again…

Thanks in advance.

Edit: I think I finally found some firmwares and manage to flash them (wow finding them was murder).

v1.0.0 AT v22 - Failed to disable Echo
Nodemcu integer 2015 07 04 - failed to disable echo.

I am using Software serial

Any other hints? @vshymanskyy?

I’m currently looking into other options for the library implementation in this scenario.
v1.0.0 AT v22 should work. I think I had AT version: 0.40.0 also working.

1 Like

check double the connections rx and tx;
first power up the arduino, and than the ESP

I finally found the link for this: v1.0.0_15_03_20 ATv0.22. Finding what you need to make this work for the ESP8266 is just about impossible :frowning: No guarantees this will work - I’m going to try flashing it tomorrow when I am not so fried from endless web searching …

BTW the best tutorial on flashing the ESP8266 I have found is here


1 Like

Success :smiley: After finding documentation for the addresses of all the firmware binary files for my device (an ESP-01), I successfully flashed the firmware to 1.0.0/0.22 and got Blink to talk to the Mega 2560 it is attached to. I noticed, however, that while the ESP started at 9600 baud (AT commands) flashing it at the required 115200 left the Baud rate at 115200. I had to change the sketch to use this speed. The important part was this: when using the wrong Baud rate for the ESP in the sketch, I got the “Failed to disable Echo” message. Thus, this message may also just indicate that you’re using the wrong Baud rate. Try connecting directly to the ESP using an FTDI cable and Putty and see what Baud rate works for the AT command interface and then transfer that to the sketch.


1 Like

@Rom3oDelta7 as you probably have them to hand can you please provide the 4 required addresses for the ESP-01.

Here’s the details. I have flashed 3 different ESP-01 boards with this and they’re all working great. Be sure to follow the procedure in the previous post for flashing instructions. There are a lot of steps involved.

  1. I had to change the results of the SpiAutoSet to manually set the Flash Size to 4Mbit. Different ESP-01 boards have different flash sizes, so check for your particular one.

  2. The Flash tool will actually tell you what has to be loaded where. (This neat feature is not documented in the aforementioned instructions.) Just load the boot_v1.2 file first and then hover over the file name. A Message box will come up with the remaining files and their addresses. I used the following. (If you don’t have a 4Mb/512KB flash then these may not work for you.)

    FIle Address
    bin\boot_v1.2.bin 0x00000
    bin\blank.bin 0x7E000
    bin\esp_init_data_default.bin 0x7C000
    bin\at\user1.512.new.bin 0x01000

  • Note that user2.512.new.bin is not used.
  • I did not try the beta version of the boot loader (boot_v1.3(b3).bin as the 1.2 one worked fine.
  • The readme file in the bin\at directory also says that blank.bin should be loaded at 0x3E000 as well but in my case that was not necessary.

I also found that the ESP-01 out of the anti-static bag operated at 9600 baud to start, but was set to 115200 after the device was flashed.


EDIT: I have started loading blank.bin at 0x3E000 just in case. It’s recommended and doesn’t seem to hurt, so …


1 Like

Thanks @Rom3oDelta7 I will work through your details but where did you pick up the various bin files?

I have just downloaded AT22SDK100-2015-03-20-boot1.2.bin from http://esp8266.ru/download/esp8266-firmware/AT22SDK100-2015-03-20-boot1.2.bin and used the single bin flashing tool ESP8266 Flash Downloader from https://drive.google.com/file/d/0B3dUKfqzZnlwVGc1YnFyUjgxelE/view?usp=sharing

With this tool there are no addresses to worry about and AT+GMR at 115200 baud gives:

AT version: 20 2015 10:04:26)
SDK version:1.0.0
compile time:Mar 20 2015 11:00:32


There are much newer SDK’s but whenever I try them and the 4 address flasher I lose all AT control of the ESP-01’s. The addresses you give are confirmed on Espressif’s github page at https://github.com/espressif/ESP8266_AT/tree/master/bin

I have a hard drive full of bin files but I think my problem is not really knowing how much flash my ESP-01’s have.

Edit: I see where your bin files are now at http://bbs.espressif.com/download/file.php?id=250
I think I have tried these but will give it another go.

You are a star @Rom3oDelta7 after weeks of playing around with the flash tool you fixed it for me by adding “I had to change the results of the SpiAutoSet to manually set the Flash Size to 4Mbit”.

I thought the tool was able to work out the flash size. Disabling SPiAutoSet and selecting 4Mbit was the trick.

Even when I was flashing my firmware as requested In this tutorial http://www.allaboutcircuits.com/projects/update-the-firmware-in-your-esp8266-wi-fi-module/
I set it to spiAuto set and the flash size was set to 8mbit

Are my problems due to this…?even though my updating was successful and on my AT commands the updated version is shown.

Yes the probably are. You probably have a 1 MB ESP i.e. 4 mbit module and the flasher has guessed incorrectly. Reflash and you should be trouble free.

I did this too…
See no hope… :sob:
I’d probably dump my esp now. :unamused:

I’ve gotten past the flashing step, but I’m not yet home free :disappointed_relieved: It’s very odd - I can get my code to work just fine on a Mega2560 using Serial1, but not on an Uno with hardware serial OR software serial. There, I’m back to the “Cannot disable Echo” error message. Looking at the library code, connectWiFi() stops sending initialization commands if it gets an error trying to send an ATE0 command to the ESP. It’s unclear why this happens, as I can do it manually in a terminal window just fine every time.I’ve resorted to following all of the library code too see if I can add some more debug statements to figure out why this is happening. You can’t set it ahead of time either, as the AT+RST command resets it to echo. Even stranger, the ESP will stop responding to AT commands when I hook it up to the Uno (either hw or sw serial) and require a reflash. Not so the Mega. :confused:

If we wanted easy, we would have gotten a $50 Adafruit WiFi shield and been done with it. It’s not rewarding unless it’s challenging :wink:

1 Like