Sharing using qr code to Android not working

Hope everyone is doing good?

Has anyone had an issue when sharing a project using the qr code, project made in IOS but sharing to Android.

The Android just wont see the code and load?

I have managed to share other projects with him, but for some reason it wont pick this one up? His wifes Iphoone worked fine, just his android wouldnt work.

I had a look on here but didnt find anything conclusive that we could be doing wrong ? Any suggestions?

Many thanks

If you can share the QR code, we can try to scan.
Does it say invalid code or any error ? Or just keeps scanning the QR code ??
And also see if your app is updated.

Just double checked it again, it loads fine on an iPhone but not on an android .

Thankyou for taking the time to reply.

I’ve deleted the shared project QR code.
There is no way to revoke shared access on a per-user basis!


sorry i dont understand why it got deleted?


Because you would have given the whole world access to control your project, and the only way to undo this would be to recreate your project, pay another 1000 energy units and share it again.


but im using the code to share access, and then i generate a new code which then revokes access?

I dont mind sharing it as its offline at the moment, unless im missing something.

Okay, if you’re happy for it to be public the I’ve un-deleted it for you.


Yes theres nothing major in there .

Thank you Pete.

i had refreshed the code, so this is the one to use now if anyone is willing to try it on an android phone.


I just scanned it on my android phone, and i am inside the project. I can see a joystick widget and button.

EDIT: I had an Samsung J7, and when i scan the code, the code on the screen looks smudged[not exactly but kind off] or i can say pixelated !..

But when i open just the camera app i can take clear pics no problem, and with other QR code scanning apps i had no issues.

i also forced closed the app(Blynk) and tried again but nothing helped. May be something like this may be happening.

ah lovely, so i just got him to do it again, still couldnt scan direct from the front page with the camera but he gets an option to use a saved image in the top right, so hes used that to locate the file hes saved from his email, so his work around was to save the code and view it all from one device rather than having two devices…

Here what he gets on his phone. He uses the little paper icon.

Sometimes there are issues with QR scan on different devices, that’s why we implemented 2 different qr scanners in the app for different devices, and allowed scanning qr from the file - have you tried scanning from the file? Also in top right corner there is a button which should enable/disable autofocus - it can also help.
Can you provide any information about the device with the scanning issues? Manufacturer, model and Android version, Thanks

That’s how he got round it by scanning from file in the end which is good enough.

I like the idea of the scanning from file but On an iPhone it doesn’t come up which is a shame which means you have to use 2 devices.

I saw it has been suggested to use the scan by file, much easier method, hope it comes for iPhone too.

Similar issues here:



I have the same issue
Blynk app v 2.27.17
Android v 7.0
Xiaomi Redmi Note 4

1 Like