BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

New Blynk Library Release v0.5.3

@Leothi yes as usual. Blynk reports it’s version on every startup.

I wrote the entire sketch, I know what is happening :stuck_out_tongue: and wasn’t really asking for “assistance” per say, but confirmation and a way to disable the suspect culprit.

However I should have focused the picture on the relevant question… My bad

34

This started happening right after I reflashed with the new library… along with more stuttering in performance. Ergo, the “new” process governor is assuming my smoothy running sketch needs control… to the point of making it not run smoothly anymore.

Unfortunate :frowning: Some of us like to push the limits of our sketches to achieve desired results.

Hmm… Are you sure it’s the timer, and NOT another throttling/flood protect :face_with_raised_eyebrow: Just asking, haven’t flashed anything with 0.5.3 YET…

And… you haven’t forgot to modify BlynkConfig.h, right??

1 Like

Confirm. BlynkTimer has nothing to do with the flood governor.

Right… so you CONFIRM it has changed, or that @GunnerTechTools forgot to modify his files??:thinking:

image

OK… my bad here… Again.

This error was actually from my Virtuino App :blush:

I had unplugged a NodeMCU running Virtuino code so I could use the USB cable to flash my ESP32 running Blynk code as something gibbered up it’s OTA…

Now, why it is displaying this error in the Blynk App is a mystery… unless it is like the Notifications and is simply a system wide Android message… but not a discussion for here methinks :stuck_out_tongue_winking_eye:

As to why I am seeing more stuttering in that particular Blynk code after the Library upgrade??.. Well, I will have to work that out on my own :sunglasses:

Wait… what? If you are referring to port or the WDTmods? I don’t need them… it was just more sluggish and the App sometimes stalls out or lags behind on some things… without the sketch itself slowing down or throwing errors…

But not to worry… I just deBlynkified that testbench project and am now working with an external display and SimpleTimer directly… it is more an experimenting project then IoT anyhow,

I tried it sometime ago, I hate it
:joy::joy:

@Blynk_Coeur could you explain cons/pros compared with Blynk? Just an opinion? Thx.

I updated the Blynk Library to 0.5.3 on my Particle Photon via the Particle Web IDE. Upon verifying the code I got multiple errors from the terminal.println commands in my code. The error was " ‘class WidgetTerminal’ has no member named ‘println’ ".
To remedy the situation I am using the 0.5.1 library. I have no idea what was the previous version. I’ve been running the same code for at least 3 months.

Thanks for reporting. We will fix it (should be easy) @BianchiRider

when I started with arduino a year ago, I started with virtuino.
but I was a noob.
I never understood how it worked. :smile:
then, I discovered BLYNK, and thanks to the community, everything was clear!
yesterday I watched again virtuino, of course there are some nice widgets,
the size of widget and text are scalable ,and no need for a server either.
but I do not even know if I can share the application on several mobiles,
in short, I do not know which is the best, and I do not really want to change!
:monkey::scream::face_with_raised_eyebrow::wink:

This is probably more a Lounge topic :slight_smile: no need to promote the competition after all… but I did bring it up and @vshymanskyy did ask :stuck_out_tongue_winking_eye:

“best” is the wrong discriper… just different. And I most certainly am not changing… however, I am working on combining :stuck_out_tongue_winking_eye:

I have successfully ran a script on a single NodeMCU that uses both Blynk and Virtuino… allowing me to mix and match my desired custom static display options using Virtuino’s widgets that seem a bit nicer (to me) than some of Blynk’s (for a cross room visual readability)… but I still have all the overwhelming larger widget quantity and IoT features of Blynk.

The documentation is poor… but the base process is very similar to Blynk with virtuino.run(); and virtuino.vMemoryWrite(12, counter); // write counter to virtual pin V12 type commands.

I admit it… that is one of the drawing features… I really like the rotating knob/slider widget and the nice looking round needle gauge… and the scalably LARGE text option (as long as you like the 7 segment look) but some of the in-widget colour schemes are not customisable (i.e. needle & text).

And it has an image widget!!! (Pro only)

Of course I am only using the free version… I have no idea what all the pro version widgets look like… and even at only $10.99 CanadianTire Buckazoids I will have to wait awhile to justify it.

BT or WiFi with direct network (device as AP or via router) connection and no server (but apparently a virtual device in the App can act as a server in the Pro version).

4 Likes

@GunnerTechTools
thank you for your explanation
the best thing for this app is to be able to use both portrait and landscape mode
that’s really what it misses most from BLYNK
:wink:

4 Likes

How to add more “likes”?? Maybe that way: :heart::heart::heart::heart::heart::heart::heart::heart::heart::heart:

2 Likes

Hi all,

I’ve noticed that devices running library version 0.5.3 don’t show up on the Library Versions tab under Hardware Info on my local server.

Scenario:
I’ve got five ESP8266’s running Blynk - two running library 0.5.2 which are displayed on the Hardware Info tab but the remaining three that are running 0.5.3 are not displayed.

Thanks

1 Like

It’s a toast message, if your virtuino app is running in background it could somehow produce a toast, but that is not a correct way to show such things on Android. Blynk app is almost not using toasts (there are just several places where we left them).

1 Like

I concur… NO 0.5.3 version hardware is displaying in my Admin page either

1 Like

@ThatGuy_ZA @GunnerTechTools Fixed with https://github.com/blynkkk/blynk-server/issues/1160

2 Likes

A post was split to a new topic: Blynk v0.5.3 with TinyGSM 0.3.5 libraries, modem does not respond