New Blynk Library Release v0.5.3

:point_right: NOTE: This version contains security/stability bugfixes. It’s HIGHLY recommended to upgrade asap. :point_left:

Be sure to use the latest Arduino Core for your hardware (2.4.1+ for ESP8266 is required)

In this release

  • New boards support

    • Arduino MKR GSM 1400
    • U-blox 2G/3G modems
    • Quectel BG96 modem
  • New features

    • TinyGSM updated to 0.3.5
    • All Arduino MKR devices now support 128 Vpins
    • terminal.clear() support
    • Add setDeviceName for ESP32 BLE
    • Cloud OTA support for ESP32
    • Board info is now parseable from firmware binary (for OTA)
    • Important: When BlynkTimer struggles to run multiple times (due to a blocked loop), it just skips all the missed intervals, and calls your function only once. This now differs from SimpleTimer, which could call your function multiple times in this scenario.
  • Bugfixes

    • Fix ESP32 BLE advertisement for iOS
    • Fix NTP time for ESP8266 SSL
    • Fix param[index].asInt() crash if index out of bound
    • Fix WidgetTerminal data length handling
    • ESP8266 now uses native dtostrf function

PlatformIO, Particle, ARM mbed and OpenWRT packages have been updated accordingly.

Grab the update here:

:star2: BTW, if you like Blynk, don’t forget to give us a github star! :star2:


And that’s a great, long awaited feature update :smiley:


5 posts were split to a new topic: Blynk Library v0.5.3 + ESP8266 floating point issue

Is this the resultant error? If so, can this feature be disabled? As it is apparently interfering with what was previously a fast prossessing, but smoothly running, sketch.

You need to diagnose your sketch to understand what exactly goes wrong. I can say nothing by just looking at the pic.
I’d say, the new behavior is what most people are expecting. No way to disable it.

1 Like

Yeah, that was one of the reason, I was using Blynk/Simple Timer with “care taken” :wink: And where not applicable - a “manual” time counting was necessary.

1 Like

Do I have to reupload the code to my board to confirm the changes?

@Leothi yes as usual. Blynk reports it’s version on every startup.

I wrote the entire sketch, I know what is happening :stuck_out_tongue: and wasn’t really asking for “assistance” per say, but confirmation and a way to disable the suspect culprit.

However I should have focused the picture on the relevant question… My bad


This started happening right after I reflashed with the new library… along with more stuttering in performance. Ergo, the “new” process governor is assuming my smoothy running sketch needs control… to the point of making it not run smoothly anymore.

Unfortunate :frowning: Some of us like to push the limits of our sketches to achieve desired results.

Hmm… Are you sure it’s the timer, and NOT another throttling/flood protect :face_with_raised_eyebrow: Just asking, haven’t flashed anything with 0.5.3 YET…

And… you haven’t forgot to modify BlynkConfig.h, right??

1 Like

Confirm. BlynkTimer has nothing to do with the flood governor.

Right… so you CONFIRM it has changed, or that @Gunner forgot to modify his files??:thinking:


OK… my bad here… Again.

This error was actually from my Virtuino App :blush:

I had unplugged a NodeMCU running Virtuino code so I could use the USB cable to flash my ESP32 running Blynk code as something gibbered up it’s OTA…

Now, why it is displaying this error in the Blynk App is a mystery… unless it is like the Notifications and is simply a system wide Android message… but not a discussion for here methinks :stuck_out_tongue_winking_eye:

As to why I am seeing more stuttering in that particular Blynk code after the Library upgrade??.. Well, I will have to work that out on my own :sunglasses:

Wait… what? If you are referring to port or the WDTmods? I don’t need them… it was just more sluggish and the App sometimes stalls out or lags behind on some things… without the sketch itself slowing down or throwing errors…

But not to worry… I just deBlynkified that testbench project and am now working with an external display and SimpleTimer directly… it is more an experimenting project then IoT anyhow,

I tried it sometime ago, I hate it

@Blynk_Coeur could you explain cons/pros compared with Blynk? Just an opinion? Thx.

I updated the Blynk Library to 0.5.3 on my Particle Photon via the Particle Web IDE. Upon verifying the code I got multiple errors from the terminal.println commands in my code. The error was " ‘class WidgetTerminal’ has no member named ‘println’ ".
To remedy the situation I am using the 0.5.1 library. I have no idea what was the previous version. I’ve been running the same code for at least 3 months.

Thanks for reporting. We will fix it (should be easy) @BianchiRider

when I started with arduino a year ago, I started with virtuino.
but I was a noob.
I never understood how it worked. :smile:
then, I discovered BLYNK, and thanks to the community, everything was clear!
yesterday I watched again virtuino, of course there are some nice widgets,
the size of widget and text are scalable ,and no need for a server either.
but I do not even know if I can share the application on several mobiles,
in short, I do not know which is the best, and I do not really want to change!