BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Local server No-ip

Hello!!

I am trying to access my raspberry pi through WAN. But due to dynamic ip one cannot access it. So i have setup the No-ip account and also logged in to No-ip from my router as well so that it updates the No-ip website when ever the public ip changes.

But now even after port forwarding when i check the ports from port checker it says it is closed. Here is a screenshot of my router page


I also disabled my windows firewall setting just to make sure the firewall is not blocking any ports. I also created a rule in the windows fire wall to allow the required ports (Inbound and Outboud rules)… But as the server is running on RPI3 this should not matter !!

And i am not sure whether is the right way it should be or not !!
on checking the ip on what is my ip
it gives me 49.20x.10.xx

on my router
IP Address 10.241.68.2xx
DNS Server 8.8.8.8, 49.206.75.x

I am not sure what is wrong or is this the way it works !!

And in the blynk logs :point_down:

Hardware SSL server listening at 8441 port.
HTTP API and WebSockets server listening at 8080 port.
HTTPS API, WebSockets and Admin page server listening at 9443 port.
Mqtt hardware server listening at 8440 port.

I have forwarded all the ports but still i am not able to access it !!

And in the Blynk app in the custom section what is the ip address i need to enter ?
Can i enter the NO-IP domain name to access the local server ??

I know this is nothing to do with the blynk !! But i went through the forum and couldnt find any good solutions !! So i am looking forward for help !!

This sounds very odd. Either your ISP is using a Double NAT System, or you’ve done the “what’s my IP” query from a device 5gats not connected via the same router.

Pete.

1 Like

Yeah may be a double NAT problem. Because I checked the what is my ip from the same router where the local server is running.

So what is the solution for this ? How to overcome this problem?
But after setting up the No-ip this double NAT should not be a problem right ?

Since he got a (private) 10.x.x.x IP in the WAN settings, you’re probably right.

Sorry, but that won’t help in this case. I think you have to contact your ISP and ask them if it’s possible to get a public or static IP.

2 Likes

So rest of the settings what i have followed is right or wrong ? So as per you guys its totally a problem of my ISP and nothing to from my end !?

Can i get internet from my phone by turning it into an hotspot ? Will this work ? Has anyone tried this before ?? Are all the telecom companies using this annoying Double NAT system ?

It looks okay to me, but then I don’t use a local server (but I have done lots of port forwarding in the past).

Not really. You’d need a way of forwarding the data relevant to your local server and i doubt that you can do that on your phone. Some mobile providers will be blocking the relevant ports anyway, so even if you had a 3/4G router it nay not work, see this:

Double NAT seems quite common in some countries, especially in Asia. More on it here:

Pete.

I assume you are using https://www.actcorp.in/ as your ISP?! After some searching, it kinda looks like double NAT is common with ACT. ACT doesn’t have enough IP4-addresses to assign each user with its own public IP, hence the double NAT.

That’s certainly what the admin screen shows:

image

Pete.

@distans
Yes i have subscribed for ACT Fibernet.
And i am going on trying n trying on something that doesn’t gonna happen like a fool !!!

But i am not an network engineer or anything close to it. But i had done a quite a bit of research on the internet.

Is there any way around this problem? Or should i opt for any other ISP ? Or the same ISP can provide me with a static ip ?

I think you need to be talking to your ISP, not us.

Pete.

Yep i know ! Only they can answer. But i have always got exact thing to b done. So if any one says no then there is no need to talk to the ISP, when there is no provision at all.

But as you have seen my router settings, can you point out any mistakes? Because incase if i get a static ip i need not open a new topic.

Nothing is leaping out as being incorrect.
Test it when you have a static IP and come back and report on whats happened. If it fixed the issue then that’s useful for others in your situation to know. Details of what the ISP said, and the cost of a static IP address would also be useful to others.

If you’re still having issues then update us on what they are, along with nes screenshots.

Pete.

Yes ! I will keep it updated.

It’s probably ISP related.

  1. Find out your external ip (https://www.whatismyip.com/)
  2. Set up some accessible like a web page on your pc.
  3. In the router open up port 80 and point it to your pc’s ip.
  4. Check your web page by typing http://your_pc_ip or http://localhost.
  5. Turn off wifi on your cell and using a browser, type http://your_externeal_ip. It should bring up your web page.
    If so, your NAT works. If not, your external ip is shared so you need to talk to your ISP.