BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

How to setup my Blynk local server so that I can use it from out side my local network

@amitkray31 Try netstat -ant on the console and share the result.
Then you can at least see if the ports are open on the server side.

Btw: On my local server I’ve set force.port.80.for.redirect=false

tcp6 0 0 ::1:631 :::* LISTEN
tcp6 0 0 :::8440 :::* LISTEN
tcp6 0 0 :::9443 :::* LISTEN
tcp6 0 0 :::8080 :::* LISTEN
output is like this

@amitkray31 Where in your forwarding rules is the IP address of the server defined? I don’t see it in the screenshot in one of the previous posts.

In my route I’ve set something like e.g.
incoming port: 8080 // forwarded to: 192.168.1.200 port 8080

You mean this

in internal ip section I put the local ip of my machine(ipV4 address)

Try disabling IPv6 on that interface as it’s not listening on IPv4… if you don’t know how to do it use THIS link.

Hello,

This is a bit more complicated, as may some people think. So I am here to guide you trough this process, but there are some requirements you (your internet connection/your ISP) need to meet. I will not be explaining the whole thing as it is, because it is unnecessary and time consuming. I will go with you trough setup step - by - step.

So, first requirement is: You have to have PUBLIC ip (not to confuse with STATIC ip, as this is another thing). How to find out if you do have public IP? Well:

  1. Go to some website that will show you your IP for example: https://www.whatismyip.com/
  2. Open your router settings (navigate to 192.168.x.1 - usually), and look for something like “Internet address” or “Gateway IP” or if you will be not sure wich one is that right, just post screenshot here.
  3. If your router internet IP matches IP displayed by whatismyip website, then you very likely meet first requirement, IF NOT, then it is very likely that you are behind double NAT - read - screwed.

After this I will tell you what is your next options - good luck!

P.S. This has nothing to do with ports, or your sketches for now.

1 Like

yes I have got my public ip. what next?

Okay, so, if your router internet IP and your actual public IP matches, then you should have public IP. Now we need to know whether you have dynamic or static IP. Does your agreement with ISP say anything about it? Or perhaps description of your internet program? Try to find out.

My router’s internet IP and Public IP didn’t matches together. I have created a WAN IP with the help of no-ip.com and using it I can connect to my server locally but not worldwide.

please forward the 8080 and 9443 port on your router. if you already forwarding ports then test the port if its really opened: http://www.canyouseeme.org/

Could you tell the procedure on how you obtained a public IP.

@Msprg is trying to explain it the right way (correct me if I am wrong)

Most ISP’s in India(Assuming you are from India) use dynamic IP and port forwarding features are disabled for domestic users. if you need to have those features you will need to get a static/Public IP address for your router from your ISP (extra charges applicable). Once you have your public configured most of the things you are trying would work.

You can forward any port from your router. But you have to configure your router to do so.
First login to your router >> go to advance settings. Here you will find option to forward port.
Here is the link for more instructions https://portforward.com/router.htm

I used no-ip.com to create my WAN IP. (There are several other software to do the same)
Create a host name [xyz.ddns.net] at no-ip.com. After that download DDNS update client and install it to your sever computer.
After installation login to your router >> go to Advance settings>> DDNS.

[if you want to use no-ip service for free then your created HOST name will be automatically deleted after 30 days and you have to recreate it again]

2018-11-19-155955_1366x768_scrot
[UI will no be the same]

I previously was trying to connect to my home computer through remote desktop connection over the internet. But, I was not able to do so. After some research I found out that my ISP (ACT fibernet) blocks inbound connections and to enable those you will have to take a static IP connection. they took the MAC address of my router and assigned a static(public IP ) for my router. after which I was able to connect to my PC remotely over the internet.
So firstly make sure your router internet IP matches IP displayed by whatismyip website.
Hope this helps.

As I said earlier, this is not so easy as “Just forward those and those, and it will work with a snap of a finger”! Also any service like no-ip.com or dyndns will not work like magic, and thus does not solve everything.
I said:

You said:

But then you said:

So that looks like you does NOT meet the very first requirement, thus, it is a bit unclear, as how you are replying, so, we can try to test this again, so:

  1. Open start menu
  2. Search for “cmd”
  3. Open application “Command prompt”
  4. In the black window wich shold appear, write:
    tracert 80.211.207.110
  5. The output copy and pase here as reply to this post, or just take screenshot of the output.

We will see if that helps, good luck.

My router’s internet IP and Public IP didn’t matches together.
I am not using Windows os I am using linux.
Thanks a lot for your cooperation.

Those are different terms for the same thing… Internet IP == Public IP == WAN IP == the IP your Internet provider gives you … How could they not match for you?

Well, you might not know it, but this is really possible. It may seem strange to you but I am (will be - not to lie) a Network engineer with a few certificates from companies like Cisco, so yup, this is really not even possible, but fairly common. It is the way that ISPs are saving IPv4 addresses. In fact, as IPv6 addresses became pretty common and with high support even on the low end devices, there are so much of them, that ISPs could/should give every person at least one public IPv6. But most of them don´t.

1 Like

@Msprg not sure if you were responding to me or the OP… but I guess I am lucky as my ISP actually supplies me with two (2) public IPs for free (one by default), same with the other big and small players where I live. Even a small WISP I worked for ages ago handled all the internal routing to give the clients such as required.

So, if as you say is the case for this OP, then I think the issue is that he/she needs to contact said ISP and get that remedied… or forgo the WAN side connection option. Nothing we can do here about it.

On the linux is the steps pretty much the same:

  1. Fire up the terminal,
  2. Write and execute:
    sudo traceroute 80.211.207.110 -I
  3. Post output here…
1 Like

Well, this does not have to be the truth. He/she is not the only one wich is struggling with this issue. I thought about it, and there is a pretty simple, smart, reliable and cheap way of tricking this “restriction”. I have an idea, but no one on “higher place” to make it happen.

Well, lucky/unlucky - it really depends on things like location, country or competition between IPSs. Somewhere you can get a ton of free public IPs, somewhere you can get one wich you have to pay for, or you even might not be able to get any of ISPs in your reach. You could say lucky, and you could say being on the right place at the right time :smile:

1 Like