iOS 2.25.0 Beta Release

The 2.25.0 update is now available for beta testing. To install the app, open this link on you iOS device:

What’s new:

  • New widget: Image Gallery
  • New widget: WebPage Button
  • Support for up to 255 virtual pins
  • Added badge showing number of offline device
  • Led: now resizable
  • Tiles: you can change TemplateID number
  • Slider/Tiles : added “Auto” decimal format
  • Timer: time can be set in run mode
  • Timer: added “Reset” option in time input dialog
  • Email: added “Content Type” setting
  • Terminal: added “Add New Line” setting
  • Number input: added “Suffix” setting
  • Number input: now supports showing NaN values
  • RTC: timezone can be set in run mode
  • App Preview: Device setup: auto connect to Wi-Fi named “Our Product”
  • GPS Stream: added sender parameter
  • Other bug fixes and improvements

Note: installing beta build(s) will overwrite the one from AppStore.


Bummer… Testflight requires iOS 10+ and my poor 4s just doesn’t make the grade… I finally get an iPhone for testing IoT on and it is obsolete :stuck_out_tongue: Life story in there somewhere :sob::sob::sob: :rofl:

Opps… I didn’t read ALL the little wordy things… I don’t need stickers, whatever that refers to :smile: OK, back to testing.

I’m waiting for Android release :stuck_out_tongue_winking_eye:

Ok, not exactly sure where to post this…

On the only project that I am using the image widget… as soon as I loaded it up on the iPhone, it showed the image (doh). The kicker is, it instantly STOPPED showing the images on ALL my Android devices! :face_with_raised_eyebrow: I mean the URLs are still there, just not doing anything…

iOS beta stole my pictures :rofl:

iPhone and Android screenshot side-by-side…

Graph is also doing something strange (on iOS Blynk)… oh, wait, that is the numbers :blush: Retina display this is not :wink:

1 Like

I also ran into one of my projects, that while it will respond to the device commands (blinking LED), and show any changes I make to widgets from other phones (Androids), it will NOT allow any control of the device (slider, buttons), nor will any widget manipulation register on other phones .

Strangely, I can only see this issue on this one project??

I sent a log file from that project page.

In this image I tried speeding up the slider and turning off the stepper motion from the iPhone… nada response from the device or the Android… but the LED still flashes away on both.

I hadn’t really followed the Android image widget thread in too much detail, as I don’t have any Android devices.
I’m running the iOS beta version and was a little surprised/disappointed at the way the image widget has been implemented. It’s great at doing what it says it does, but if press/release events of the widget were sent as BLYNK_WRITE events then it would be a much more powerful tool. It could be used as a switch widget, which could be made to behave differently on short and long presses (via code of course) and even disabled/greyed-out by having a grey version of the image and corresponding code to not respond to press events.
This functionality is something I’ve requested here:

In the future, are there plans to add the image functionality to existing switch types (On url, Off url - as well as existing On/Off colour and text)?

One minor issue that I did find with the webPage button.
If you don’t supply a fully qualified url then the app crashes when the button is pressed. I realise that the hint text implies that https:// is required, but if a url without the https:// prefix is used then it ought to be handled in a more elegant way than simply throwing the toys out of the pram :open_mouth:


1 Like

Sure, this is just first version. Button image is planned too.


1 Like

Sounds like you may have modified the project (like assigning pins, etc) on Android while iPhone was already opened and running? Try to stop/run project from iOS, or go to About → Reload Account or just relaunch the iOS app.

This is already fixed in upcoming Android update

1 Like

Nope… just started from the left and worked my way to the right, through all my running projects to test them with the beta iOS app… found this one that acted strange.

Tried all that… uninstalling and reinstalling App again (once I figure out how… :stuck_out_tongue: iOS newbie )…

… OK, that worked :smiley:

Ok, then… But yeah, very strange. I saw your logs, but couldn’t make much of analysis since you’re on local server and I couldn’t check what widgets/configurations didn’t respond.

1 Like

Not sure if this a Beta issue… The App sees, but is unable to connect to Light Blue Bean, a BLE device. Even though I can and do use the same iPhone to upload the program to it (and tests Ok with other limited function Apps). Tried a few times and sent log

I’m not sure whether it should. Does the very same setup work ok if Android phone is used instead?

Well, currently the Android Beta WILL at least connect, but I only get limited functionality from the App/device link… some BLYNK_WRITE() functions work, albeit laggy, but no Blynk.virtualWrite() do.

Was told that might be fixed in next release.

@Eugene, just an FYI. When pressing the [i] button to get more information of how the WebPage Button works, it brings up the info for Styled Button, which is incorrect.