BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

How to define user role without spending $499

So I need to share a device with users but the default user role allows a user to do absolutely nothing and the documentation says you have to edit the user role so they can see their own devices.

Unfortunately for just this small change I need to pay $499 which seems a little high

Only workaround is to set all users to Staff level but that means they can see al devices, even those under development and not yet released by me.

Any other suggestions?

Unfortunately this is a pro plan feature.

I know - I was hoping that even for Plus plan the default for the User role would be to be able to see their own devices. I don’t want to edit roles, just have a User role that functions

The plus plan is not a commercial plan, it’s for personal use only so all the devices assigned to your organization belongs to you not to the user.

The pro plan give you the ability to change the device ownership, check this out https://docs.blynk.io/en/blynk.console/devices/actions-with-devices#device-transfer

Strange thing is , even in Plus plan I can change device ownership (I have done it) it’s just that because the default User role is pointless and actually has no permissions that the User cannot even see their own devices.

I don’t know exactly what you mean with “can’t do absolutely nothing” but i’m on the plus plan and gave my wife user access. She can do exactly what you suspect a user can do and that’s full use and change of all widgets, but no permission to change anything design like.

@bazzio in my system you can see that anyone with a User role cannot do anything - they cannot even see their own devices. I would expect User to be able to see their own devices and not the organisation devices.

Stange… here are mine settings

@John93 Any idea how I should get my profile for User role reset so it’s the same as bazzio?

In the Roles and Permissions screen do you have an “Edit” button at the top right?
If so, then I think you should be able to turn-on “View Devices” and “Control Devices” for the User role.

If you try to change any permissions that are greyed-out for your Admin role then you’ll get an error message when you try to apply the changes.

Pete.

Sadly I don’t have Edit button as I’m only on the Plus plan. Basically my configuration is wrong and there is no way to fix it.

Have you tried a different web browser ?

@Dmitriy may be able to help you change the setting to what you need. Try sending him a PM with your login email, and the settings you would prefer. Maybe he will set them for you.

Just spotted that you don’t have any users added (0 users), did you already tried to add one?

No need. This is @Pavel requirement.

Err no but the problem is Blynk User role configuration not my browser

Yes but since they cannot do anything I changed the role to Staff

This is an error. User role has pre-defined set of permissions, but definitely not zero.

@Dmitriy looks like a bug

@Pavel I flagged this issue up on 1st July, but then you said it was done this way by design…

Pete.

And other people have a sensible set of permissions for User role even on this plan so how do I get these corrected?