Blynk Library v0.5.3 regression: ESP8266 floating point issue

There seems to be a problem with the new version.

Using ESP8266 and a virtual pin, a float variable is being received by Blynk as zero. It works fine if I revert back to V0.5.2.

This has been out for a few days and no one else has mentioned any issues with virtual pins, floats, or another general process. I know all my projects seem to work as normal.

Are you running all latest versions of Blynk… App, Local Server (if used)?

You need to be a bit more specific and show some code and data that clearly demonstrates the issue. I recommend you create a new topic with this information.

I appreciate what you are saying Gunner.

I have been working on a Temperature Monitor for a few weeks - everything was working fine.

Today, I built some new hardware (ESP8266 + DS18b20). I don’t regularly update the apps on my iPhone but checked today and there was an update available, so I installed the new version. I also checked the Blynk site and noticed that there was a new library version - V.0.5.3 which I installed. I compiled and uploaded my sketch and had the problem of a float appearing as zero in Blynk. I replaced my float variable with millis() and that worked as expected. After spending an hour or so checking my hardware, I plugged in my previous hardware (sketch complied with V0.5.1) and it worked as expected.

So, I reverted the library to V0.5.1, compiled my sketch and uploaded it to the new hardware and it worked as expected - so, the new hardware was fine, the new app version was fine, but there was a problem with v0.5.3 of the library. I then installed v0.5.2 and it also worked as expected.

My sketch is nothing special, and just uses the standard

Blynk.virtualWrite(V5, tempC);

where tempC is declared as a float

float tempC;

For now I am happy to use v0.5.2, and maybe it is just me, but it thought it would be useful to report what appears to be a bug.


Not useful if it is a red herring :stuck_out_tongue_winking_eye:

I just tested sending a simple float to a display with Blynk.virtualWrite(vPin, floatData); and it works fine.

Maybe you need to update your ESP8266 Arduino Core. What version do you use?

BTW, this is tracked by - and old issue that now hits several users

1 Like

Wow… 2015… Not so much a red herring as a rotten old fish :stuck_out_tongue:

I am running Core 2.4.1 so probably why it is working fine for me.

Thanks everyone.

I have now updated to Core 2.4.1 and Blynk V0.5.3 and everything is working as expected - I was using Core 2.3.0,

I guess the lesson is to try to keep everything updated, but that is sometimes easier said than done!



I have the same problem.
But I can not find how to upgrade the core.
I downloaded this archive with the new core.
And what’s next?

Are you using Arduino IDE? If so, it should be in Board manager and you should receive notification about possible update.

1 Like

Just follow the directions.

1 Like