BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

0.23.0 - 0.23.1 Server port changes

Dear all,

in latest server version some ports were changed.

Admin port : 7443 -> 9443 (merged with HTTPS API); Since 0.23.1.
Plain WebSockets port : 8082 -> 8080 (merged with HTTP API); Since 0.23.0.
SSL WebSockets port : 8081 -> 9443 (merged with HTTPS API); Since 0.23.0.

2 Likes

For what reason we’re they changed :slight_smile:?
Ports are not my strong side so I’d love to know!

Simpler setup, quicker start, also we preparing server for future enhancements where only 2 ports will be used 80 and 443 as many users have problems with non default port.

1 Like

Is it possible to change these ports back?

Yes. You can do port forward.

In the new Blynk server (0.23.1) I can’t get in the admin browser. In the previous this was 192.168.1.xxx:7443 and now it supposed to be 9443 but still get unable to connect. While I can still use the app and the HTTP API.

1 Like

@hutje blocked 9443 port?

No, I didn’t block anything. I try to enter 192.168.1.112:9443 but only got unable to connect on my browser… I will try it straight from the pi as localhost.
And my server.properties is:

http.port=2020
allowed.administrator.ips=0.0.0.0/0
allowed.users.list=xxxxxxxxxxx@hotmail.nl, xxxxxxx@hotmail.com

server.ssl.cert=./server.crt
server.ssl.key=./server.pem
server.ssl.key.pass=xxxxxxxxxx

Well, It doesn’t mean it is not blocked. You need to check that.

Are you trying to access the admin panel from the server machine as that is how you currently have it set up?

This is what I always had. And now I can’t access the adminpanel

@hutje I take it from your statement the answer is yes.

So what do I need to change?

Sorry, to be more precise, I normally can connect from any computer in my network to the Blynk admin panel using 192.168.1.112:7443, but now I can’t connect from any computer in the network both 7443 or 9443.
I still need to check if I can connect on the Pi itself with localhost. But is it possible I need to change the server.properties?

Report back when you have done that.

Yes.

@hutje what exactly url you are trying to access? Please post it here

Is it possible to only ping this port from the pi itself? Otherwise I need to install a desktop on the RaspPiZero…

@Dmitriy I normally use http://192.168.1.112:7443
Now I tried http://192.168.1.112:9443 but got unable to connect.
I tried https://192.168.1.112:9443 but got warning that site may not be safe, clicked ignore and I was redirected to blynk.cc.
Also when I use http://192.168.1.112:2020 I am redirected to blynk.cc

@hutje you don’t need a desktop on the Pi to access the admin panel.

Actually allowed.administrator.ips=0.0.0.0/0 is access for all IP’s so that shouldn’t be your problem.