With 0.5.2 my Blynk is not connecting anymore… using Mega with Ethernet

Sorry, with 0.5.2 my Blynk is not connecting anymore… using Mega with Ethernet.
is Release Note “Switched port to 80 for Particle platform” relevant for me ? If so what is required to change

You mean old devices or new devices flashed with this library?

@klaus313 Are you confident it stopped working with 0.5.1 -> 0.5.2 upgrade?

I will cross check again… I did upgrade 0.5.0 -> 0.5.2

so… it seems I have some more issues (don’t know if related to version update or not, but I have not changed anything else …)
1,) with 0.5.0 it worked fine until update , no issue
2.) with 0.5.2 it tries to connect to www.blynk-could.com:80 but it never gets connected
3.) back to 0.5.0: it connects to www.blynk-could.com:8442 quite after restart, but losses the connection immediately and tries to reconnect but never get connected again …

never change a running system !

you have www.blynk-could.com:80 or www.blynk-cloud.com:80 in your code?

typo - sorry … no I don’t have anything like “www.blynk-cloud.com:80” or similar in my code

Did this topic die for lack of interest?

@mpo881 Please start your own topic with complete details… adding “similar issues” to “not connecting anymore” is adding vagueness to uncertainty :stuck_out_tongue_winking_eye:

Ok I can do that. It didnt seem necessary to duplicate a topic.This one has been sitting idle for 3 days with no resolution?

But it is not YOUR help topic :wink: and you might have differing aspects.

Ok, I give up. No, it is not my topic. Does that mean I am not allowed to ask what happened with this one? Ill edit my post to leave out my comment that I have similar issues. Then can I ask what happened to resolve this issue?

@Gunner this is actually may be the same issue. Please do not remove comments right away. We never do that :slight_smile:.

@mpo881 in last few days many things happen, so you may be affected by one of them.

  1. Exploit that uses Cisco routers vulnerabilities. All ISP providers have that equipment and in last recent day many ISP providers all over the world have problems with connectivity;
  2. Our hoster had a bit another issue in the USA datacenters (for last 2 days). At the moment they are fixed.
  3. Few changes on the blynk side regarding new connection ports (8442 -> 80, 8443 -> 443).

If you still have connectivity issue - please provide more info like serial debug print if posisble.

1 Like

@Dmitriy Thank you for your reply. I can reply later today with additional details.
Thanks again


@Dmitriy @Gunner

Here is what I can tell you

IOS v10.2.1
Particle Electron
Hologram sim
Blynk Library v0.5.1 (v0.5.2 is not an option in particle IDE, yet)
Blynk App v2.18.0

Prior to upgrades, connected and ran fine
upgraded both app and library then only connected to cellular, not blynk cloud, no info on serial monitor via debug and electron in endless loop of connecting to cellular, disconnect, connect.

I then loaded sketch Blynk Blink from sketch builder. Added new project and button widget D7 to control built in LED on Electron. Connected and ran correctly.

Back to my sketch. Tired many different things-too many to remember and probably not important anyway. What finally solved it was to refresh auth token. Ran exact same code (mine) that would not connect since upgrades, with new auth token-connects and runs fine. So, the only change to my original code since the upgrade was to add a new auth token to the same old code with the same old project on the app.

Go figure

Thanks for your help

1 Like

@mpo881 thanks for the update. This is very strange. I don’t think that token was a reason. Have you reflashed hardware with the same token? Maybe reflashing changed something.

My project consists of a server and 6 slaves that communicate via nRF24L01. So, as I have been testing I was adding nodes 1 at a time and checking stability. In that regard, I was flashing the same auth token. But now of course that token is gone.

1 Like

I’m stilly trying to get blynk running with V5.1 or higher but I have not success: (version 5.0. works fine with port 8442

BLYNK connects see message below:.
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v0.5.4 on Arduino Mega

[5716] Connecting to blynk-cloud.com:80
[5814] Ready (ping: 21ms).
BLYNK connected

Then nothing happend anymore …
May be its because Blynk is using port 80 since V5.1. On my router there is another server running on port 80 ( I can not change this) Maybe this is the reason for it so what kind of possibilites do I have to get it solved ?
Thanks for help

Well yes, this shows that you are connected… What else is supposed to happen from here on? What are you running for your sketch?