Why ENC28J60 is not working with BLYNK

Hi everyone, i am new here. My problem is Arduino Uno + ENC28J60 + Blynk. Why this combination is not working for a simple led blink and moreover there is no tutorial is available for this combination. I am using Blynk library for ENC28J60 then what is the problem ?? Please help me.

It’s very well possible to use it, I run it all the time.

What exactly is your problem? How have you setup and wired everything? Can you also post your code? I’d love to help, but you are nog giving us much information to work with :slight_smile:

thanks for your response buddy. So this is the code

#define BLYNK_PRINT Serial // Comment this out to disable prints and save space
#include <UIPEthernet.h>
#include <BlynkSimpleUIPEthernet.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = “582b2db6359542b0b421b4b7f66bb844”;

void setup()
// You can also specify server.
// For more options, see BoardsAndShields/Arduino_Ethernet_Manual example
//Blynk.begin(auth, “server.org”, 8442);
//Blynk.begin(auth, IPAddress(192,168,1,100), 8888);

void loop()

And serial monitor is showing

[0] Blynk v0.3.1
[0] Getting IP…
[1253] My IP:
[5001] Connecting to cloud.blynk.cc:8442

now what to do brother??

Very old blynk library?

1 Like

Well, it looks like you got things correct. Is that IP also what you use on your local network?

Can you put your code between three backticks ` ? It’ll make the layout really nice.

It is old, but not extreme, but it’s a good notion yes. Updating to 0.3.4 is advisable.

Cloud.blynk.cc is working now?

Yes it is:

Connected to cloud.blynk.cc.
Escape character is '^]'.
telnet> quit
1 Like

Yes it is…

Why Blynk app is showing that Your Arduino UNO is not in network? How to fix this problem? What are the changes i need to do with code just tell me. I am not good at computer networking. Help me buddy.

How is your ENC wired to your arduino? It looks correct, but it can never hurt to check. Also, is that IP address correct?

Connection is like this.Is it ok?

VCC – 5V

  • GND – GND
  • CS – D10
  • SI – D11
  • SCK – D13
  • SO – D12
  • INT – D2

That should be fine. Can you try disconnecting the INT pin? I don’t think that is actually used.

Another thing to check is your firewall(s) on routers. Can you at least reach the cloud.blynk.cc server via telnet on port 8442?

How to check it ? Can you tell me the steps?

From your computer open a command prompt and type:

telnet cloud.blynk.cc 8443

If you get connected it’s probably not a firewall issue.

It,s showing a blank page

Actually I meant 8442, but ok. Did you use the browser or telnet? I don’t think it matters much, but ok.

Have you tried disconnecting the Int pin?

yeah i tried with 8442 also and i disconnected INT pin. I have a doubt , i am connecting my enc28j60 directly with LAN board and my laptop is connected to internet via wi-fi so what is the meaning to check telnet in my laptop CMD ? If i m doing some mistake then please let me know and guide me.

It’s just to make sure you can reach the Blynk server and it’s not blocked by a firewall in your router.

Can you try connecting the Arduino via USB on your laptop? It may be that you have a bad ENC module. You could also try with an ENC example to see if that works.

I am connecting ENC module directly to LAN board without using a router module. Is this a issue ?

And yesterday i got something on my serial monitor which was:

[0] Blynk v0.3.1
[0] Getting IP…
[1253] My IP:
[5001] Connecting to cloud.blynk.cc:8442
Ready ping (265ms)

so what does it mean ? am i connected now ? And Blynk app was also not showing that Your Arduino UNO is not in the network.