BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Video stream with esp 32 cam not working

I am using an eps 32 cam module. It streams well on my browser but I am not able to use it with my blynk application. The link myipadress/stream works for me on my browser. When i tried to use it with the blynk video streaming widget, it did not work.
I configured the widget in such a manner:


Sometimes, there was an error message saying unable ot start video stream and sometimes there is just a play button with all grey background.
I have connected my mobile phone to the same wifi network and i made sure that no other stream tabs were open in my mobile or laptop as well. I saw tutorials on youtbe and they ollowed the exact same procedure but still i don;t know whats the issue. Can anyone help me with this, please!

You have t assigned a pin to the widget.
Im not sure if this is needed, but it’s a good idea to assign a virtual pin to the widget, as I’ve seen situations where an I.legal URL can prevent the app from starting.
Assigning a pin can allow you to change this and rectify the issue.

Are you running the latest beta version of the app for your phone’s O/S?
If not then you should be.

Pete.

@PeteKnight This is the version of the app I am using. I don’t see an update option so I guess it is the latest one
image

I tried using it with a virtual pin as well. Still, i got the same result - grey widget and not working

This is what i used in my code to initialize the url to the virtual pin:
Blynk.setProperty(V1, “urls”, “http://IP/stream”);
And in the video stream widget I also chose v1.
Please tell me how to solve it.

Start by signing-up for the beta version.
If you are using Android then you scroll down in the play store and you’ll see the option.
iOS requires TestFlight to be installed.

urls (with an ‘s’) is for the image widget, not the video stream widget, and there is no need to do this in code if it’s set manually in the widget.

Pete.

@PeteKnight, i updated to the beta version. Now, i started the video streaming with the same url as above. This is the result i get.




Please help me out

1 Like

I think the issue is on the ESP32Cam side (most likely current streaming software needs “streamlining”) as that is the same results I get as well… and can’t even get that in Virtuinos web widget (but other IP cams work). However, after much fiddling, it eventually streams to Blue Iris.

So basically what I am saying is I don’t think it is a Blynk issue.

1 Like