Vertical scroll issue


i have a very annoying issue with the “vertical scroll” function on the project page. it is a bit hard to describe, but i will try:

when the project is stopped, and i’m adding new widgets, if i try to move a widget just one line under the visible page, it suddenly jumps to the very bottom of the last page (ie. it scrolls down several pages, completely to bottom). so, i can not place widgets only to the first page (anywhere), or only to the bottom of the last page.

after placing a widget on the bottom of the last page, if i try to move the widget a bit upward, it suddenly jumps back to the first page. there’s no in-between positions.

the only way i could place widgets on the second screen, is i have to fill up completely my first page with adding several widgets, then, it begins to add the new widgets to the second page. but this is very annoying, because if i want to place a widget to the second page, first i have to fill up the first page - with unneeded widgets.

i have tested with the latest app, on 3 different android phones, it was the same behavior. (restarted phone, cleared memory, reinstalled app, etc)

i hope this is not the expected functionality of the vertical scroll…


Thanks. @BlynkAndroidDev will check this at some point.

Very strange, and we had never before heard of such issues. I’ve prepared a log build, that could possible help in finding the cause of such strange behavior.

i’ve sent a log from my galaxy s5 phone (android 6) + allview v40 (android 4.2) phone.
by the time, i searched my old motorola xt925 phone, with android 4.4, installed the log build on that, and there it worked perfectly. very strange.

i see you already implemented the offline device monitor :wink: very cool, thanks!

Seems I know the reason of this scroll issue. Maybe you have disabled animations on your devices, so that’s why all animations a happening immediately in their end state.

1 Like

yes, thats true. i have disabled animations.
what is the reccomended value to set?

Probably default - 1x

ok. i will set and test

i have to enable all of them to 1x?

Animator duration scale should be enough

ok, if i enabled only that one it helped partially.
but after setting all of them to 1x, it works flawless.

…and guess what: widget resize works too :slight_smile:

thank you for the patience and pionting in the right direction!

ps: i will link this solution to the other widget resize topics

1 Like

I’ve thought that it would also have impact on the widget’s resize. Great, from now we’ll know that developer options has some settings that could lead to such behavior.

sorry for causing lots of stupid problems for you!
i didn’t know the cause, and i’m not big fan of animations in os, this is why i always disable them, also on windoze pc and android phones. but i have enabled them now, and i can live with it.

It’s great to know that such things could occur on user’s devices. As I missed availability of such settings in developer options.

@BlynkAndroidDev, just a personal idea regarding the offline device monitor:

i would rather put the number directly into the chip icon, instead of the circle. the circle is very small, and it is difficult to see the numbers.

you could make the chip icon change color from black to red, and put the numbers inside it, with a bigger font.

when all devices are online, the numbers dissapear and the chip color turns from red to black.

Wow, you have 14 devices? But it should not be a circle in such case, seems it is UI bug in this case.

no, actually i have more, just 14 are offline :slight_smile:

It should look like a rounded rectangle in such case. I’ll check what has gone wrong.

i think it would be better put the numbers directly inside the middle of the chip icon. than you can use a larger font, and no hassle with additional circles / rectangles, also easier to the eyes.