Using same blynk project on two different phones

It is no worries. My reply was to be sure. If you found that zip file on the wiki link I sent you earlier then yes that is the correct file.

Thank’ you

Well, I must report that I have had to remove Blynk from my project. :sob: Without being able to have the Arduino connect to the server, it caused so many problems that I was not able to run my project correctly. I have no clue what changed on the server end of things but I can assure you that my sketch and my hardware remain the same as they were during the initial testing when Blynk worked with my sketch and my hardware.

I really like the app so I am hoping you can find out what went wrong. When I remove the blynk code from my sketch my project works fine again.

Just curious if we have made any progress?

Thanks much


Yes, @mpo881.

I investigated the problem in details, and now I understand what happened.
Probably you were using IDE 1.0.6 before, and switched to 1.6.*
These versions handle libraries in a bit different ways, so you get the error (which is correct!).

Look, this shield uses its own library, and it is not integrated into Blynk yet. So please note, that changing the line:

#include <Ethernet.h>


#include <EthernetV2_0.h>

is not enough.

The reason “it worked”, as you say, may be in some level of compatibility between the chips (W5200 vs W5100).
In this case, try running with unmodified Ethernet example.
This will be exactly as it was during early testing.

Please tell us how it goes.

Thank you very much. I will give it a try and let you know how it went.

How did it go? Did you get it working?

No I have not had any luck yet. I have made some changes to the code in an attempt to resolve it and it corrupts other parts of the code. If I remove all of the Blynk code, my sensors work as they should and message me when they should. When I add things back in, sensors and messages stop working.

I havent given up yet. It is somewhat frustrating because my project had worked with Blynk in the past. But, that is how it goes when you are trying new things.

Does any simple Blynk example work with your HW setup (shield, etc)?

I have given up on the other ether shield and have obtained an Arduino Ether shield with PoE. I did use the sample ether code from Blynk and was able to connect successfully.

I am now able to connect to my project and obtain sensor data. I have the sensors set to update via the Blynk app every 30 seconds which they are doing correctly.

I also have some switches that I am trying to get to work. As of right now, they do not work. I have tried to assign both virtual pins and the digital pins. No luck, Ill keep working. Any suggestions on the switch issue would be appreciated.


FYI, I just timed it and it took ten minutes and 15 seconds to turn on a light using the same connection that is updating the sensor data every 30 seconds. Any ideas would be appreciated.


I ran another test on my project. I have 5 gauges that read battery levels. I disconnected one of the Bat V in connections on my PCB. The appropriate gauge on my touch screen dropped to zero while at the same time the value reading on the Blynk app read zero. I also received a text message that Battery 5 was low. So, you can see that this part works as expected. The Battery V in is connected via a voltage divider to A12 while the value display widget is assigned to V8 in the Blynk app.

None of my switches, which are assigned to digital pins on the Arduino and digital pins in the Blynk app work. I have defined a virtual pin map for Blynk in my Arduino code and have tried using Virtual pin assignments for the switches in Blynk that match the map in Arduino. Still nothing.

As a friendly reminder, this code did work during testing along with the ether shield that I have now replaced.



One further point to avoid confusion…the switches assigned to Digital Arduino pins do work on my uLCD touch screen, just not with the Blynk app.



Brian, sorry for being silent for a while. We are investigating your issue. @vshymanskyy will contact you as we have questions, or, better, a solution.

Our apologies for that

While you are waiting, could you share your project code and try debugging:

  1. Put this line at the beginning of your sketch

     #define BLYNK_DEBUG
  2. Upload it to the board

  3. Start Serial Monitor and tell us what you see when you press the buttons.

Could you please share your code?
You can send it to if you don’t want to publish it here.

Do you mean, that you have a Button Switch Widget, set it to Digital Pin 10 for example. On physical pin 10 on your device, you have something like relay or transistor (or a simple LED) and it is not working?


I will email my code to you.

I have a relay assigned to a digital pin. The relay is controlled by a switch on uLCD. That same relay will be controlled from the outside world with Blynk via a Button Switch Widget. The switch on uLCD works, the Button Switch Widget does not. At the same time however, the data from my value displays works fine.




I have sent you a couple of emails. Please let me know if you did not receive them




I do not know if you have received any of my emails or not. When I send them to you, they come back undeliverable. I resend them and they seem to work, no message on the second try?

Anyway, I will wait to hear from you.


oh, my bad, it should be

Ok so did you get any of my emails then?

I guess Ill resend