Using same blynk project on two different phones

When creating a new project Blynk assigns a token. Is there a way to copy that token in to a different phone so that both phones can control the same project? Or would I simply paste both tokens in to the sketch?

Thanks

1 Like

@mpo881

You could login under same account and in that case you’ll have same token on both phones. Right now this is only option for your case.

1 Like

Thank you for the reply

Dmitriy,

There must be another step that I am missing. I downloaded the app on an android device and logged in with the same credentials that I use to access my project on my iphone. Once logged in, the only option is to create a new project. This new project has a new token. Since there is no way to alter the token, I am at a dead end. Do you have any further advice?

Thanks

@mpo881

That’s strange. Are you sure you using same email? We checked those cases. Should be working.

Yes, the credentials are the same on both phones. I still have had no luck.

Thank you

I am not sure what is going on really. When I do manage to log in, I sometimes get a message that says my Arduino Mega is offline. But I know that is not the case. My project involves a motion alarm and when I test that, I get a text message telling me that motion was detected so I know that the mega is connected. When I connect my laptop to the Cradlepoint router, I am able to access the web and it is fast reliable connection.

When we were in the testing phase, it was working well. I have not changed my sketch at all except for the new token.

Also, when I am able to connect without any error messages, I notice that my gauges (temp, battery levels, etc) work as expected. However my switches (lights, etc) do not work or work extremely slow.

I am working with my cell provider to have them check on their end. That was the purpose of me using the android device to see if I had a better connection with a different device on a different network.

Thanks

@mpo881

Please send me dmitriy@blynk.cc your email you logged in under. So I could check logs. It may help.

Dmitriy,

I did send you two emails now. Perhaps I am in your spam folder? I understand you are busy so no worries. Just making sure you got my messages.

Thanks

Brian

@mpo881

Yeap, just found them in spam =). I found 2 emails Brian. 1 ending with “gmx.com” another with “gmx.us”. Could you please tell which one is correct and which one you are using and which token you uploaded?

@mpo881

My suggestion is - in app you using “gmx.com”, while uploaded token from “gmx.us”.

Just one thought, I was using the .us email address since first starting to use the app. I have never logged in with .com.

I will give it a try

Thanks

Well, I am lost. I have spent a lot of time testing and trying to eliminate problems. Here is what I know. Prior to the last server upgrade I was able to connect to my project and Blynk worked well with it.

Since the upgrade, I have a difficult if not impossible time connecting. The hardware and sketch are the same. I have created a new Blynk account with a gmail address along with a new Blynk project and token.

I have tested my connection to the internet and it works well. I have tested my project and it sends me messages as it should when the conditions are met.

So, even though I show a good connection and I can receive messages from my project to my cell phone, I still cannot connect to my project via the Blynk app. It still says that my Arduino is offline.

Again, I did not re-write the sketch since testing of Blynk concluded. Was there an update to the Blynk library perhaps that I missed? Since the new server upgrade is there something that needs to be added to my sketch?

This is all very frustrating to have had it all working correctly and now it has all gone away.

Thanks

Brian

@mpo881

Brian,

here is some bug exactly with your setup and your mails.
you are saying you are not using “gmx.com” but exactly it was updated today. “gmx.com” has 2 tokens:
first starts from “56eba”, second starts from “ff5a7”.
gmx.us” has no widgets in profile at all and has token start from “f3a18”.

Please check your code and tell me which one token you had uploaded to arduino.
Also try to logout, close app and login again. (In early versions there was a bug - login acc didn’t changed after logout, this is exactly what you could catch).

Please tell me your findings…

Dmitriy,

Thank you for your reply. I have made some progress by using my gmail address. The token that I am using starts from “c66890”. I can now log in to either phone with those credentials and see my Blynk project. It still however keeps telling me the Arduino is not on line.

I have connected my laptop to the Cradlepoint and am clocking respectable speeds so I know that I have connection to the outside world. So, I have no idea why my Arduino is no longer connecting to the Blynk server? I can get messages from my project when the appropriate conditions are met.

Brian

Has there been a change to the Blynk library in regards to the ethernet shield? I am using a Seed Studio ethernet shield V2.0 here;

http://www.seeedstudio.com/wiki/Ethernet_Shield_V2.0

When I try to compile my sketch with #include <EthernetV2_0.h>, which is what I have been using since testing began I cannot get my sketch to compile and get this error message;

Arduino: 1.6.0 (Windows XP), Board: “Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)”

In file included from C:\Documents and Settings\Brian\My Documents\Arduino\libraries\blynk-library-0.2.1/BlynkSimpleEthernet.h:14:0,
from Jackpot_V_1.9.2.ino:13:
C:\Documents and Settings\Brian\My Documents\Arduino\libraries\blynk-library-0.2.1/Adapters/BlynkEthernet.h:21:22: fatal error: Ethernet.h: No such file or directory
#include <Ethernet.h>

                  ^

compilation terminated.
Error compiling.

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.

If I comment out #include <EthernetV2_0.h> and instead use #include <Ethernet.h> my sketch compiles correctly. However, I do not know if my project will connect to the internet with using Ethernet.h instead of EthernetV2_0.h. I will have to test it to find out.

Again, I have noticed these difficulties since the server was updated just prior to Blynk going live.

Thanks
Brian

Sorry, we don’t support this shield yet. The list of supported hardware is here.
We are collecting information about what shields are more popular and implement them.

If you’re an experienced developer, you may look in the library code and hack your own shield integration.

Huh? Well that makes absolutely no sense? This is the only shield that I have ever used INCLUDING as an early tester. Are you saying that now that you have gone live it will no longer work?

Please clarify

Thank you

By the way, I forgot to add that it worked just fine during testing. Again, please clarify what you mean. If it worked before, it should still work unless there is something new in the new release or since you upgraded the server just prior to going live.

Hey, I’m glad to hear that it worked…
By saying that it is not supported, I mean we do not test it to see if it works. So yes, something could break.
How can I know that it worked before? ) I didn’t understand you correctly.

Ok, let me check if I can get it compiling with this library. Are you using this one?
http://www.seeedstudio.com/wiki/File:W5200_Ethernet_Shield_Library.zip

Sorry for confusion.