BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Use the My Apps utility for esp32?

I have a system using myPlant demo code of esp8266 for success but I also want to use this code for esp32. What should I do, hope to receive help from people. Thanks for watching.

To start with, change the Blynk 8es8266 library for the one used on the ESP32… you can see the different librarys in the Sketch Builder

https://examples.blynk.cc/?board=ESP32&shield=ESP32%20WiFi&example=GettingStarted%2FBlynkBlink

1 Like

yes i tried but it does not work

@H_i_Hoang
The export demo contains a special example for ESP32: https://github.com/blynkkk/blynk-library/tree/master/examples/Export_Demo/Template_ESP32
It does not contain any myPlant-specific logic, you can merge it from the myPlant example if needed.

@H_i_Hoang Please stop posting screenshots… copy and paste your code… properly formatted of course :slight_smile:

Blynk - FTFC

Also, no need for a 2nd account… the blocking was due to the full screenshot postings.

2 Likes

@H_i_Hoang
Hi Hoàng, pm mình giúp cho!

I just tried compiling your code for esp32 but it failed to compile. Can you compile? Looking forward to receiving help.

Yes, I use a few different ESP32s with Blynk… no problems compiling.

Have you loaded in the ESP32 Arduino core in your IDE?

yes, has i been using esp32 with blynk for 3 months now and now i want to transfer it to My apps in blynk’s app

I also tried to compile template_esp8266 and was successful. But with template_esp32 is not and the error as below.

Arduino: 1.8.5 (Windows 7), Board: "ESP32 Dev Module, QIO, 80MHz, 4MB (32Mb), 921600, None"

In file included from sketch\BlynkProvisioning.h:16:0,

                 from C:\Users\xaneo\AppData\Local\Temp\arduino_modified_sketch_53621\Template_ESP32.ino:19:

sketch\Indicator.h:209:84: fatal error: ESP32Ticker.h: No such file or directory

compilation terminated.

Multiple libraries were found for "WiFi.h"
 Used: C:\Users\xaneo\Documents\Arduino\hardware\espressif\esp32\libraries\WiFi
 Not used: C:\Program Files\Arduino\libraries\WiFi
exit status 1
Error compiling for board ESP32 Dev Module.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Sorry, I don’t understand… transfer what to the App?

This sounds like you may be missing a library? I don’t use ticker so am unsure if it is built into the core or not.

What do I need to do to be able to run template_esp32?

I am sorry, perhaps is the translation, but I do not understand what you what to do…

Perhaps continue with @noi

I’m sorry, my English is so bad :))

There’a a comment in the code that directs to the library needed… )
This is actually included in the latest ESP32 core, but may be missing in windows, if using installer.

what do you mean? Can you help me? I really need it to work.