Upgrading local Blynk looses Auth Token, board types & Virtual Pins (and issues with iOS App)

@Dmitriy i - I just upgraded my local blynk server from 0.19.0 to 0.20.1 and also upgrade my Android and iOS apps to latest version but to my horror all the auth tokens have changed ! As well as the hardware model type shown in the blynk app. Any help as to why this occured and how I can restore would be appreciated. Same data folder used i.e. -dataFolder c:\home\Blynk

Do you have old profile file?

unfotunately not - is there some way in the local server I can type in the auth token for each project ? I have the auth code and I can change the board type in the blynk app. Will that work ?

You need to stop server. Go to data folder find you profile and manually put auth to “devices” field.

hi dmitriy something appears to be seriously broken.

I edited the auth as per your advice and it worked; only if I also change the hardware type as well (i.e. Arduino MEGA + Ethernet) as a first step from the local server admin page then as a second step changed the auth code in a text editor. Then I run the blynk app on Android and all is well… However when I then run the app on iOS it changes the auth token to some other random number and does not display the correct hardware type AND then everything is broken again i.e. the Auth is changes and the hardware type is changed ! iOS App overwriting auth etc.

Do you have multiple devices on Android?

no - just one device per auth project. i have 6 projects, 2 x mega, 1 x wemos d1 r1, 3 x wemos d1 mini

hi @Dmitriy
just to help with trouble shooting :slight_smile:

I am using blynk local server 0.20.1 and I finally (manually) got the auth tokens changed to the correct ones. Also, in some cases the app lost the virtual pins settings as well for buttons etc, so I had to re-configured them manually too.

Once this was fixed the Android app showed correct hardware (once I changed it) but when I then went into IOS it defaulted to Arduino 101 - so IOS app was not picking up the hardware info from the server correctly [I only have 1 hardware per auth token].

Just a fews mins ago I updated to server 0.20.2 and found the auth tokens had changed again when I went back into the Android blynk app to some random number :frowning: , so I need to change them back again !

So something weird going on when upgrading local server and also when switching from Android to IOS app. Have you been able to re-produce this ?

No. This screnario should work if you don’t use multi devices.

any idea why would this be occuring on my setup ? everything was working fine until I upgraded to latet Android release and blynk server release

one further question :slight_smile:I have two files in my server directory:

I assume the blynk server uses the first one i.e. “Blynk.user” and not the second one ?

I assume the blynk server uses the first one i.e. “Blynk.user” and not the second one ?


Please try to create project from scratch. Does that help?

Problem could be also in widgets that are present in Android but not on iOS.

could be - but I not using any Android widgets that are not available in iOS. I get the feeling iOS has different hardware profile to Android and its getting all confused.

On the other issue of upgrading server and loosing Auth tokens is a weird one as well - any ideas on why that may be occuring

hi @Dmitriy, apologies for multiple notes - however I feel it would be of benefit if I provide you with further details on the issue.

Everything is working fine on local server 0.20.2 and latest Android app.

However, once I then log in on my IOS app (latest version), the Hardware selected on the IOS app appears as Arduino 101 NOT Arduino MEGA as selected on the Andoid App. Also, when I log into the IOS app I am now seeing that the widget virtual pins have gone - i.e. each widget has lost its Virtual pin assignment.

That’s correct. This is not yet implemented.

Bug. But we can’t reproduce it.

hi - is there someway I can help you find the issues ? can I send you (directmail) the blynk config file ? would that help ? or some other log file.

I can recommend for now to do not use Android + iPhone until iPhone will support multi devices. Catching issue may take a lot of time while it is simpler just to implement multi device on iPhone :).

I guess I’m stuck for now :frowning:
Would be nice if I was able to update auth token from within blynk server web page rather than work through files - any chance that little update will sneak in the future ? :wink:

Yes. We will release some day nice web dashboard.