BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Unable to access jarfile server-0.41.6.jar

Hello ,
I’am new here i tried to make my own Blynk local server and here is the issue i have been through,
when i enter the cmd line

java -jar server-0.41.6.jar -dataFolder C:/Server

also tried this

java -jar server-0.41.6.jar -dataFolder C:\Server

all i get is

Error: Unable to access jarfile server-0.41.6.jar

keep in mind that i have installed the latest version of java JDK 11.0.3, unzipped the blynk-server-master zip file on the same server folder with the server-0.41.6.jar file and also when i try to open the file server-0.41.6.jar by my self it runs and then i can access my local server only on my computer by the following link :
https://192.168.1.2:9443/admin
but i cant access it on my phone while following the instruction opening it on my phone.
notice that i also tried to run the cmd prompt as an administrator and i got the same massage.
also ports that i opened on my router are 9443 and 8080, then deleted 8080 and kept the otherone by itself and still nothing.

where is your file server-0.41.6.jar ? same directory than your cmd line ?

1 Like

Yeah.!

please sceenshot your “cmd” windows

1 Like

Sure

you need to be in c:\server , not \users…

1 Like

Good point , thanks
But Now it moved on to this

You need -java8 version of a jar.

2 Likes

You are not using last Java jdk but java8
Try 0.41.6.-java8.jar

1 Like

Thanks to you guys this point passed but another problem came out and i think its related to ports ,
now in the cmd it passed and it said:

Blynk Server 0.41.7-SNAPSHOT successfully started.
All server output is stored in folder ‘C:\Server.\logs’ file.
Your Admin url is https://192.168.1.2:9443/admin
Your Admin login email is admin@blynk.cc
Your Admin password is admin

but when i try to log in with my phone here is what i get

Sorry, app could not initialize connection to the server

here is my router ports


and here is how i log in with my phone, same port same ip.

i really appreciate your support :smile: .

The hardware devices use 8080 and unless you are using the devices outside of your local network, port forwarding that is not usually required.

But the App uses 9443, so if you want full access to your Local Server from your phone, when outside of your network (AKA on Cellular instead of WiFi), you need to port forward 9443. EDIT - I see, in small detail with the screen shot, that it appears you already did. But why are you using your local IP for the remote host?? I would think the router would automatically assign its public IP to that.

I also find that using a DNS redirection address in the App, instead of the internal IP (when on WiFi) or the public IP (when on cell) helps it work regardless of whether my phone is on WiFi or Cellular link.

I use www.noip.com

1 Like

Thanks for your replay
now i don’t need opening 8080 so i removed it , also i edited 9443 port’s remote address and leave it blank as you said so that the router will automatically assign it


still the same problem with logging in with my phone.
I will try noip.com later if i need it as right now i only need to access it within my network.

Your phone MUST be connecting the the WiFi in order to use that internal IP.

Also, can you confirm that your server is staying running… how are you starting it?

1 Like

but what do you see on the PC navigator when you connect to 192.168.1.2 (blynk server) ?

1 Like

Connected to the same netwrok,
When i try to visit the following addresss with my computer its okay and iam in.

https://192.168.1.2:9443/admin
Also
https://192.168.1.2:9443

What appears when i enter it a page that requires user name and password and iam in when i enter the admin account with blynk green logo and its fine

good point.on the app of your phone make sure your are on the same ssid and type 943 instead of 9443.

1 Like

@Shalabyer In your App, you need an account (not the admin one) in order to log into it… Where you able to create an account on your server (via the App)?

It should be 9443… although 433 might also work, but probably not 943 :wink:

1 Like

oops I 443 for sure :joy::joy::see_no_evil:

1 Like

When i tried to sign up with the app gives me the same output,
I wi try the 443 port to log in with the app when iam home as iam outside :smile: