Trying to connect particle electron after all the updates and server problems [WORK AROUND FOUND]

Since the server went down I have updated blynk to the newest library on particles IDE which is 3.5. I have updated the app itself, but my electron still shows out of network. my serial debug looks like this

[17580] Connecting to blynk-cloud.com:8442
[18210] <msg 2,1,32
< xxxxxxxxxxxxxxxxxxxxx (my token)
[18820] >msg 0,1,9
[18820] Invalid auth token

I have verified my auth token several times and even refreshed a new one, which also cost me another 1000 energy points to generate a new remote user link. Any help would be much appreciated.

Interesting. What does ping of blynk-cloud.com shows? Please also send me email and token you are using to dmitriy@blynk.cc

just shot you an email with my token. I don’t know how to ping the cloud I’m still pretty new with this.

Just open “cmd” in win or console in mac/ubuntu and type “ping blynk-cloud.com

It’s a cellular device not connecting through wifi

You may do ping from your PC. What IP does your hardware show?

@slimfetz ok. I see in logs your app logins, but no hardware logins. So it make me think something wrong with hardware setup. As temporary solution you may try to put those IP in sketch.

Something like that

Blynk.begin(auth, SSID, pass, IPAddress(XXX,XXX,XXX,XXX));

I don’t know what SSID and password would be

This is Wi-fi network name

i’m not using wifi it is cellular connected. My PC is not going to be connected to my hardware. Hardware is normally in remote location.

Can you post up the code that was working before?

// This #include statement was automatically added by the Particle IDE.
#include “blynk/blynk.h”

STARTUP(cellular_credentials_set(“apn.konekt.io”, “”, “”, NULL)); //uncomment for cellular

char auth[] = “xxxxxxxxxx”;

int power_input = C0;
int press_input = D4;
int pump_output = D0;
int press_analog = A0;
int pressure;
int moisture;
int temp;
bool manual_on = false;
bool auto_on = false;
unsigned long start;
unsigned long start5;
unsigned long start10;
unsigned long start20;
unsigned long start30;
unsigned long timeroll = 5000;

void setup() {
Serial.begin(9600);
Blynk.begin(auth);
Serial1.begin (9600);
pinMode(press_input,INPUT_PULLDOWN);
pinMode(pump_output,OUTPUT);
pinMode(power_input,INPUT);
digitalWrite (pump_output,LOW);
}

void loop() {

pressure = analogRead(press_analog);
pressure = map(pressure, 369, 3599, 0, 100);

if (timeroll > millis()){
start = millis();
start5 = start;
start10 = start;
start20 = start;
start30 = start;
}

Blynk.run();
if (manual_on == true || auto_on ==true){
digitalWrite (pump_output,HIGH);
if(digitalRead (power_input) == LOW){ // switch to low
digitalWrite (pump_output,LOW);
manual_on = false;
auto_on = false;
Blynk.virtualWrite(V3,“OFF”);
Particle.publish(“POWCLAY”);
}
}

(I took out all the irrelevant stuff further)

So it might be a case of Konekt needing to update it’s DNS records… But I would have thought that would have been done by now…

1 Like

how do I check on that? Is that completely out of my control if that is the case?

Remember before when I said i solved the problem by setting my DNS to 8.8.8.8 in my wifi router?

In your case the router is operated by Konekt…

1 Like

Ok Dave, as a troubleshooting step I hooked up a particle sim card and different electron and I have the same result. Device not in network. the serial says invalid auth token :tired_face:

@Dmitriy does this latest info help?

I used a photon with the same code and just changed pins so that the code would work and the app will connect using wifi. It is definitely a problem only involving cellular.

so without wanting to offend you or disparage your intelligence, have you checked:

https://community.konekt.io/