TimeInput Widget delivers ALL days selected when no day is selected

The Parameter t.isWeekdaySelected(n) of the TimeInput-Handler delivers All days selected when no day is selected. Was this planned?
In that way it isn’t possible to recognize on hardware site if all days are selected or no day.
If I don’t wanna use the weekdays-selection I just don’t check those parameters in my sketch and / or switch the weekdays-selection off.
At the moment it isn’t possible to skip weeks without a wanted action (e.g. holiday).
In that case I need to delete the start- and stop-time or need to do any other trick.
Is there a way to change this to a logical better behavior?

Thanks in advance

It is documented that at least one day must be selected and you need to work around this.

Thank you very much for your reply.
No problem even it makes no sense at all.
If you just want to use Start- and/or Stop-Time then you just disable the weekday selection.
Now it is a kind of limitation of the possibilies that the widget already have just because of setting the selection to all days if no day is selected.
As I could see on the Blynk debug output the widget delivers the right information (all days = 1,2,3,4,5,6,7 and no day = nothing).
Maybe you think about this one more time. Not for me, for all blynkers and future customers.

Wow… yesterday I have made the same question…

For me it don’t have also any sense…

I can also explain my objective… in my project can be 3 - 4 or 5 timeinputs active at same time I can set a button to disable the timeinputs that I dont want to use, but I think just not setting any day is enough to disable any time…


@darkmoon That’s really funny because I had the same thought you have. Not select any day could disable the Timer. This would be by far the most easiest way to do that. But unfortunately not possible at the moment.
Maybe the Blynk-Team can rethink about that topic and can break the limit
I would really appreciate that.
I think you would do that as well, don’t you?

@Darwini I hope so…

In this moment I have another project ready to be programmed and it’s also using configurable timeinputs…

In this moment, I have set that if every day is selected and the starttime is 6:28:15 (the time the widget is giving me when no time is selected) I set a flag in nodemcu to set the timer disabled… so tricky but functional…


@darkmoon Last friday I got the idea “Why not modify my Blynk-Library by myself?” Actually it was much easier than expected. Just replace “-1” of the code “mWeekdays = -1;” by “0”. You can find the code in line “33” of file “WidgetTimeInput.h” (Version: Aug 2016, respectively 14 Sep 2016). After that change the widget does behave in the way you and me want.
If you modify your library in the same way then I recommend to comment that change in your sketch because any update of the library could reverse the change. That will not have an effect on your compliled code but of course on new complilings as long you will not have made the same modification on the new library.
However, I hope it helps you and maybe also some other Blynkers.


@Darwini I can’t do anything else than asking myself why devs don’t want to change a -1 to a 0 in their code…

Even of that, thanks for the tip!

@darkmoon cause we have other things to do?

@Dmitriy I think Blink is a great tool, I’m sure I will use it for years, but sometimes the info you (I mean your team) give to us is a little short…
I think the time I spend to find a way to check if no day is selected and the time @Darwini spend to find this variable could be less if your team send us an answer.
Maybe I’m digging my own grave here in this community… but I need to say it…

Sorry for the inconvenience…

No problem. I just saying if something not done or not works as expected this is because we don’t have time to fix it right now and not because we don’t want to fix.

Thanks dmitriy!

I have the same problem and implementing Darwini suggested modification nothing change.
After library modification I close and re-open Arduino IDE, re-compile the sketch and re-load the sketch but no changes: all the days are selected. What I’m doing wrong???

@pielle Please create your own topic with detailed description of issue, code and what you have tried so far.