Time Input Widget Bug

This looks like is introduced recently… using iPhone App.

a) Add a TimeInput with Days selection on. Specify any virtual pin. Leave others as default values.
b) Add a button. Specify any virtual pin. Set to on/off instead of push.
No need to connect a board.

a) Set any time, lets say 9:00 AM. Select Monday and Tuesday.
b) Turn the button on.

Close the iPhone App completely.
Re-open iPhone App.

b) Button is still on. The value has persisted. This is expected.
a) Time is still the same 9:00 AM. The value has persisted. This is expected.
BUT a) Monday and Tuesday is not selected anymore. These did not persist. <====

Also, if you do connect a board (I am using NodeMCU) the BLYNK_WRITE(Vx) is not getting called when you change Time Input but it does when you change button state. I have more detail information here Time Input widget erratic behavior

@DIYTerminator Could not reproduce so far. Make sure you have the latest (2.10.1) app version.

I am using 2.10.1 (0). I tried logging off, logging on. Deleting the app and re-installing it in hopes that something may be corrupted. I also created a new project within the same app. But the issue isn’t going away unfortunately. Next I can try my wife’s iPhone.

One thing to note is that you have to completely close the iPhone app to see the issue. If you just hit the home button, that doesn’t close the app fully.

@DIYTerminator Could you reproduce the issue (with board, connected and online) and send me logs via the app right afterwards. In the email details (what pin, what value should be shown) and screenshots (e.g. before and after app relaunch) would also be very helpful.

Just tested with my wife’s iphone same results. Here is a very basic case…

  1. iPhone 7. Blynk App never installed, downloaded.
  2. Created a brand new account on Blynk.
  3. Created a project. Select NodeMCU as the board (no board actually connected for the simple test).
  4. Added Time Input Control. The only control in the project. (In the control parameters, (a) flip “Allow Day of Week Selection” to Yes, (b) set pin to V1, © leave everything else as default).
  5. No board actually connected.
  6. Start the project. Board shows offline since there is none connected for this simple test.
  7. Click on Time Input which should be the only control. Set time to 9:00 AM. Select Monday and Tuesday from the days. Select [ok]. You should see on the main app page 9:00 AM and your days selected.
  8. Double click on the iPhone home button and completely close App. (Just clicking the home button does not completely closes it)
  9. Start the App again.
  10. Time Input control shows 9:00 AM (last value retained) but the days selected are gone! (values not retained) :frowning:

Yeah I see. There seem to be a widget settings conflict. Thanks for reporting. We’ll fix.

As a temporary workaround please try to enable all switches in settings (including “Allow start/stop” option).