Stopped before I got started (SparkFun IOT Blynk box)

I am barely started. I opened the SparkFun IOT Blynk box, followed the instructions to power up the Blynk, and connect it to the Blynk app on my LG V10 phone. It fails to connect. Stopped dead in my efforts to begin using the Blynk. I can’t proceed if it won’t connect. I’ve tried several times. It fails to connect so quickly, it seems like it isn’t even trying. I’ve had no problems using other Bluetooth devices with this phone. I’m wondering if something is missing in the instructions. The app on the phone does see the correct color code and allows me to select the Blynk, but that’s it. I can’t get any further.

Additional info:

I just tried to set up the same IOT Starter Kit Blynk board using my Samsung Galaxy Tab 10.1, and got the exact same results. It will not connect. So either the instructions are wrong, the app is defective, or the board is defective.

I got this kit last Christmas, 2016, but never found the time to try it until yesterday. I don’t have a receipt, as it was a gift.

Any suggestions to make this work will be greatly appreciated. It’s not heavy enough for a paperweight.

Hello and Welcome to Blynk

While this is the Blynk forum, and we can assist in helping you learn how Blynk (the software) works, This is not the support forum for Sparkfun products. You will want to also check over at their support site, as you could also be looking at a hardware issue.

what are those instructions?

how do you know that?
any serial monitor output?

what color code?
what is the app / hardware expected to do?
what widgets are you trying to use?
any screenshots from the app?

yes, it is probable that one of the above is true.
however, feel free to ahare more info with us if you expect any help…

as this forum is not - in any way - associated with the commercialisation or support of this hardware, it clearly doesn’t matters. we will try to help you the best we can, based on the info you provide to us.

and you should provide lots of info, because most members on this forum never used such a hardware :slight_smile:

also, please read this:

1 Like

My apologies. :slight_smile:

As is usually the case when I am stumped, I am / was lacking crucial information. I did not realize that the Blynk software had its own support forum, and was thinking this forum supported everything having to do with Blynk hardware. Although I have a little experience with Arduino and Raspberry Pi, the Blynk board is completely new to me.

It appears I need to do a lot of research into how to set up a Blynk board so it connects properly via WiFi with the Blynk app running on an Android device. The short answer to how I know it did not connect is that the Android Blynk - Arduino, ESP8266, RPi app told me so when I tried to connect, following the very brief instructions bundled in SparkFun’s IoT Starter Kit with Blynk Board. I made the mistake of seeing “Starter” and thinking it meant “beginner”. Clearly that is not the case here.

Thanks for offering to help. Once I find a way to actually get a Blynk board to connect to the app, I’ll keep your offer in mind if I encounter software issues. :slight_smile:

1 Like

The board is very much for beginners. SparkFun has huge online resources covering the board you have.

Blynk IS ONLY software… the “Blynk” Board is a partnership with Blynk (the software) and Sparkfun (the manufacturer/suppler of their own hardware).

We will gladly assist you in learning how Blynk works… but it seems you first need to get your board connected… that is where Sparkfun support is responsible.

Starter Kit does imply “beginning, starting, etc…” but it is a kit requiring some technical aptitude, as are most electronic kits… and their web-page is very informative.

If however, you feel their (Sparkfun) instructions are unclear… particularly on where to go for further support, then that is something I would seriously recommend you mention on their support page (the green link above that you have not appeared to have clicked on yet) as there is not much us forum volunteers and members over here can do about that.

1 Like

however, please keep in mind that blynk evolves in a FAST pace. new app version come out every month, so the docs on the sparkfun may be outdated sometimes. but the basics are the same.

I have to give you folks credit. Even though you aren’t supporting SparkFun products, several of you have responded in an effort to help me get on the right track. I did email SparkFun tech support on 11/24. Still haven’t seen any kind of reply from them.

I’m looking through their support site, but I really do not see anything geared toward what to do if the board won’t make the initial connection to the Blynk app. It appears they assume that part will always succeed.

It seems there may be other, more involved, methods to try to determine if my Blynk board is DOA, which do not involve using the basic connection instructions SparkFun bundled to connect to the Blynk phone app. Once I read enough on those alternate approaches, where a new project is created and set up, I can see if the board is still not connecting.

Thanks for all the input so far! :slight_smile:

That was the day after Thanksgiving in 'merica… (EDIT - I guess you would know that :stuck_out_tongue: ) so, everyone is probably still suffering from turkey coma :turkey: I would have been vastly surprised if they HAD answered so quickly :slight_smile:

As I understood from your comment, you are talking about board provisioning process: you had scanned QR code, have found your board in the list on the next screen, but it is not going further or fails on trying to connect to your board?

Yes, that is exactly the case. The Blynk app instantly shows failed to connect - try again. It does this so quickly, it seems to never have even tried to connect.

Yes, I suppose you’re right. Hopefully they’ll respond soon.

Ok, we’ll check on our side. Which version of Android has your LG V10?

It’s Android 7.0

But I also tried it on my Samsung Galaxy Tab 10.1, which runs on Android 4.1.2. It reacted exactly the same.

Yep, I could not reproduce this issue on mine Sparkfun Board. Seems it connects fine to it. But I could prepare for you tomorrow a log enabled build to check what is going on on your side, if you could install it, reproduce the issue and send us log - it could help a lot in it’s fixing, if it is connected with the app side.

And what Blynk app’s version are you using?

That would be terrific! Thanks!
I have freshly downloaded the Blynk app from the Play Store, version 2.16.7.

I just tried the alternate provisioning by smartphone steps from this site (which technically has incorrect directions to acquire the authorization token - it never gets generated until AFTER you tap CREATE PROJECT, and then it automatically gets sent to your Blynk-connected email address).

I can get as far as where the Blynk board tries to connect to my WiFi, after I have entered all the required info, but I get the flashing purple “could not connect” indicator. I take it this means the board’s WiFi CAN talk to the phone then, as I had my phone’s WiFi connected to the Blynk’s WiFi as called for, but the Blynk Board cannot connect to my WiFi. I know I entered the password correctly, and chose the correct SSID (we have multiple WiFi sources here). So I need to figure out why it won’t connect.