SSL not authorized - Raspberry pi on Node.js

Not sure why @Gunner closed the same exact topic I had that wasn’t solved but I’ll take his advice and make the same exact topic again.

I’m on a Raspberry pi connecting to a local blynk server using Node.js with the following code:

var Blynk = require(‘blynk-library’);
var AUTH = ‘xxxxxauthaxxxxxx’

var blynk = new Blynk.Blynk(AUTH,options={addr:“”});

When running this I get the error on launch (and repeats over and over):

pi@raspberrypi:/home/pi/project# node index.js
OnOff mode
Connecting to: 8441
SSL authorization…
SSL not authorized

From the original post here, @vshymanskyy mentions that you need to generate the certificates and pass them to blynk. (The local server has the letsencrpyt certs intstalled and I’ve even tried replacing the certs in the blynk-library on my client with the certs from from the server).

How do I get it to connect over SSL? Unfortunately the suggestion in the last post won’t fly with me to only use a local (unencrypted) connection as the device sometimes doesn’t stay stationary to the local server.

Because you are new here you may be unaware of the time date stamps that show that topic is almost a year old.

Nor may you be aware that we have had some certificate changes in Local Server since that may invalidate suggestions from older topics.

The “solution” in that past post was to stick with the TCP connection… However, by having a current topic, perhaps there will be some new information that may work for you, so thank you for following my suggestion.

And finally, it is considered bad form to tack a “Me Too” post onto someone else’s topic… Too many independent issues make the topics hard to follow; And they are, more often as not, NOT exactly the same. PS, this was mentioned to another previous “Me Too” user in that past topic, so I am unsure as to why you were unsure :wink:

As for your case, There are few recent topics regarding issues getting SSL working… it is apparently tasking on many MCUs and near as I can tell, really only “supported” on ESP, at least as far as available Blynk libraries go BlynkSimpleEsp8266_SSL.h.

But in the documentation, there is some reference to an RPi script that you can run. Check it out, perhaps it will help.