[SOLVED] SSL not authorized - Raspberry pi - Node.js - log.level

Hello to everyone.

I am testing RPI 1 (B) with node.js. I modified the file

to my needs using my local server which is online and working properly with esp8266.

When i run the above js i get the message

Connecting to: XXX.XXX.XXX.XXX 8441
SSL authorization…
SSL not authorized

and in my blynk.log

2016-12-26 21:16:22.727 DEBUG - [id: 0xbc7a8dd8, L:/Servers.IP:8441 - R:/Clients.IP:46474] HANDSHAKEN: TLS_RSA_WITH_AES_128_GCM_SHA256

I have read the topics but i couldn’t find the solution.
Server is 0.21.1

Please Help and thank you in advance

To use SSL, you need to generate the certificates and pass them to Blynk.
Just use the TCP version for now, I will update example in next release.

Thank you vhymanskyy,

I will connect with tcp, until then.

A minor problem(?) also.
In server properties I wrote log.level=trace and left a blank space at the end of the word trace. When I tried to start the server I got a message that it wasn’t recognized and the server didn’t start.
I removed the blank space and everything worked again.

OnOff mode
Connecting to: 8443
SSL authorization…
SSL not authorized
Connecting to: 8443
SSL authorization…
SSL not authorized

any help with this problem, my sever has the ssl cert.

@imrdnck Please stick within your own thread for now… asking similar questions in multiple threads (particularly ones a month+ old) is considered spamming and only adds to overall confusion.

ok sorry

Is there an answer to this yet? I’ve scoured the internet and can’t figure out how to load my own certs. Changing the cert in the blynk_library didn’t do anything…

@James1 Please create your own topic with DETAILS of your equipment, setup and whatever you are having issues with. Thank you.