[SOLVED] RTC - Daylight Savings Still Haunts Me

I’ve been using RTC’s time, for sometime now with the ever patient help of @Gunner and others It worked great!

Then Daylight Saving Time hit !!!

OK, now RTC is one hour fast. I read the posts like an obedient “Blynk’r”, tried the recommendation of @Dmitriy to delete the RTC . Can’t get the time right?


  1. Deleted Value Displays showing time & Date (just because)
  2. Deleted RTC Widget
  3. ReFlashed MCU Again (everything but time works)
  4. Added Value Displays showing Time & Date
  5. Added RTC widget back, set with my GMT-6

Still one hour fast !!! I’m I missing some type of “Sync” command?

Stuck in the Future

I will answer now, even though you will have already seen this for an hour :wink:

Blynk’s RTC is based on this library: https://github.com/PaulStoffregen/Time

And in the discription it does reference an option for syncing with NTP servers using the setSyncProvider(provider) function

I found an a couple of examples using that NTP funtion here: https://github.com/PaulStoffregen/Time/tree/master/examples