[SOLVED] Particle Photon Shows as off line

Hi I have a particle photon that I cannot get the Blynk server to see. The Particle cloud is fine all variables and functions show in Particle cloud. On Particle dashboard I have the Virural pin published and it’s a good clean string.

When I start the Blykn sketch on the iOS device I get a message “Particle Photon is Off line”. The auth token good and I have refreshed and re-flashted the photon.

Have the “Push” rate every 30 seconds.

Any suggestions?


Hello. You need to flash latest blynk library.

@Dmitriy, the Particle IDE library is not at the latest. Can you or Volodymyr update and republish in the IDE? Thanks!

Yes. but the latest one in Photon IDE is ok too. (0.3.5)

Dmitriy, a member of the Particle Forum was told that he needs to use the latest 0.3.7 version as he is experiencing difficulties with the iOS app.

Yes I will update the particle library soon…

1 Like


I worked with ScruffR to get a compile using 0.36 Blynk library not using the IDE. The iOS app sill says “Particle Photon is offline”.

This was the latest GIT hub blynk library.

One note I have a Spark Core this is working just fine on Blynk. Can I have both a core and photon on the same blynk app? Each device has its own Token generated by the Blynk iOS app.

Inputs appreciated.


Yes, you can. I don’t know what else I could advice here. Please try to search forum for similar issues, maybe it could help.

Please post your code and serial monitor output for both devices.

Have you tried flashing fhe example sketch and see if it works?


I looked at the example and fixed my problem. I now have Particle Cores and Photon all running on the Blynk Cloud!


1 Like