BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

[Solved] "Invalid auth token"

I have searched and read many others with this problem but cannot seem to fix my problem.

So in the app I selected for a new token and received an email with:
“Auth Token : 61e36646377b4d91a79db935b8db229c”

So, if I try this:
https://139.59.206.133/61e36646377b4d91a79db935b8db229c/project

I get a blank page with “Invalid token.” at the top.

But I can ping successfully:
Pinging 139.59.206.133 with 32 bytes of data:
Reply from 139.59.206.133: bytes=32 time=150ms TTL=50

I have tried many new tokens and none of them work.

I have no idea what am I doing wrong?

Thank you for your help.

Possibly something with the way you are using the regional IP instead of the generic blynk-cloud.com

As this…

http://blynk-cloud.com/61e36646377b4d91a79db935b8db229c/project

Shows this…

{"id":755582573,"parentId":-1,"isPreview":false,"name":"Home","createdAt":1538514899241,"updatedAt":1538514968328,"widgets":[{"type":"DIGIT4_DISPLAY","id":160077,"x":0,"y":0,"color":600084223,"width":2,"height":1,"tabId":0,"isDefaultColor":true,"deviceId":0,"pinType":"VIRTUAL","pin":5,"pwmMode":false,"rangeMappingOn":false,"min":0.0,"max":1023.0,"frequency":1000,"fontSize":"MEDIUM"}],"devices":[{"id":0,"name":"HomeControl","boardType":"ESP8266","vendor":"HomeControl","connectionType":"WI_FI","isUserIcon":false}],"theme":"Blynk","keepScreenOn":false,"isAppConnectedOn":true,"isNotificationsOff":false,"isShared":false,"isActive":false,"widgetBackgroundOn":false}

Now… go change your Auth to something a little less publicly broadcast across this forum :stuck_out_tongue: and try again.

Yes, I think that works now, thank you Gunner.

I am seeing this:

    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ v0.5.4 on ESP8266

[1625] Connecting to blynk-cloud.com:80
[2071] <[02|00|01|00] 61e36646377b4d91a79db935b8db229c
[2133] >[00|00|01|00|C8]
[2133] Ready (ping: 61ms).
[2133] Free RAM: 48392
[2200] <[11|00|02|00]Hver[00]0.5.4[00]h-beat[00]10[00]buff-in[00]1024[00]dev[00]ESP8266[00]build[00]Oct  4 2018 17:18:25[00]
[2271] >[00|00|02|00|C8]
[12214] <[06|00|03|00|00]
[12715] >[00|00|03|00|C8]

Which I think is good.

But now the next problem, my app will not display this information.
I have followed the examples but it does not seem to work.

So on my Arduino I am sending data to V5.
Then in my app I define V5 as a “Value Display” and nothing shows?

It shows as:
“V5:–”

Not sure why I am having so much trouble with this?

@sd_read please post your code. Did you run your project? Is it active?

Below is my code and it is a pre-canned example which I cannot get working.

I believe the code below works based on what I posted above therefore I guess the problem is on the app?

But, it is so simple I don’t know what it might be?

/*************************************************************
Download latest Blynk library here:
https://github.com/blynkkk/blynk-library/releases/latest

Blynk is a platform with iOS and Android apps to control
Arduino, Raspberry Pi and the likes over the Internet.
You can easily build graphic interfaces for all your
projects by simply dragging and dropping widgets.

Downloads, docs, tutorials: http://www.blynk.cc
Sketch generator:           http://examples.blynk.cc
Blynk community:            http://community.blynk.cc
Follow us:                  http://www.fb.com/blynkapp
                            http://twitter.com/blynk_app

Blynk library is licensed under MIT license
This example code is in public domain.


This example shows how to send values to the Blynk App,
when there is a widget, attached to the Virtual Pin and it
is set to some frequency

Project setup in the app:
Value Display widget attached to V5. Set any reading
frequency (i.e. 1 second)
*************************************************************/

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial
#define BLYNK_DEBUG // Optional, this enables lots of prints

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = “61e36646377b4d91a79db935b8db229c”;

// Your WiFi credentials.
// Set password to “” for open networks.
char ssid[] = “???”;
char pass[] = “1234”;

// Use Virtual pin 5 for uptime display
#define PIN_UPTIME V5

// This function tells Arduino what to do if there is a Widget
// which is requesting data for Virtual Pin (5)
BLYNK_READ(PIN_UPTIME)
{
// This command writes Arduino’s uptime in seconds to Virtual Pin (5)
Blynk.virtualWrite(PIN_UPTIME, millis() / 1000);
}

void setup()
{
// Debug console
Serial.begin(9600);

//Blynk.begin(auth, ssid, pass);
// You can also specify server:
Blynk.begin(auth, ssid, pass, “blynk-cloud.com”, 80);
//Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,100), 8080);
}

void loop()
{
Blynk.run();
}

Please try the other example, which uses BlynkTimer

Thank you for your suggestion, I have it running using BlynkTimer which now allows me to continue learning how Blynk works.