[SOLVED] Eventor with Digital output or Virtual output?


I’m new to using blynk and I’m trying some widgets that I want to use in my future project.
I’m trying to use a relay at preset intervals, ie: ON at 12, OFF at 14. At the same time, I want the status of the relay can be changed manually from the application with a button and that button to indicate the status (ON or OFF )
At this point, I’m facing the following situation:

  1. If the button uses digital pin D0 (Settings: Output: D0 0-1, Mod: Switch), when I run the application, at the set time for activation (at 12:00:00 (Daily) set D0 to 1) on the screen, there is no change in button status. If the application is reloaded, the status of the button appears altered (ON in this case).
  2. If the button uses the virtual output V0 (Button Settings: Output: V0 0-1, Mod: Switch), everything is OK, changing the status appears on the screen at the set time.

What and how do you recommend to use so that I can control the action of the relay (5V) via NodeMCU at set intervals, as described above.

Thank you

in the long run, using virtual pins is highly recommended (the digital pins are for basic, newbie use case).

i’m not sure why in the first case the button status is not auto updated when the digital pin changes, probably you have to refresh manually (ie, write code for periodically read and send the status of the digital pin), or it could be a bug. @Dmitriy ?

i think i never used the digital pins directly from the app, so i have no experience with this behaviour.

Ok. I will use virtual pin for “Time” event and turn on and off digital pin at NodeMCU.

Blynk version, 2.16.4, Server: Blynk cloud

the behaviour is present on both android and apple?

can not try on apple, Eventor is not present :slight_smile: yet…

Tomorrow I will try with the development board and the relay, and I will let you know the results. And then load project on ipnone S5

Seems like a bug. We will check. Thanks for reporting.

I try to link all togheter…

in fact, my project must do: follow temperature in DHW Cylinder (NTC10k immersion sensor) - solved by some code line (thanks @wanek) and turn on/off heating element (using 16A/240V contactor) with two series relay (5V) (with two condition), will activate heating element (through contactor) - simple no? :slight_smile:

condition for relays is:
-relay K2 ON at 12:00 (event 1), OFF at 14:00 (event 2)
-relay K1 ON if temp is lower than 24 C degree (event 5), OFF if temp is higher than 24 C degree (event 6)

At the same time, may be, I need to put in ON/OFF mode, both relay at manual control.

schematics is:

(pay atention only for “INTERVAL”, “BOILER” button and level. Bottom buttons is use for another projects)

sensor reading, indicated at the “Level V”

button for relay K1, 1 to 0 to keep relay unpowered,

button for relay K1,

Eventor settings

Until now, I have a problem when syncing the buttons … When I press the button, the command is sent and the K1, K2 relays respond very well. Also, relay K1 responds and works through the sensor temperature, BUT, no relay does not respond to the command of any event …

it is two distinct issues:

  • for K2, event 1 and event 2 send command, button change status, but not action on relay K2.
  • for K1 nothing happen at Eventor command…

remark: in event 5, I put OFF instead of ON, because I want his relay not to be powered, and similar event 6

Use NodeMCU board, Android tablet

Thanks in advance

This issue should be fixed in new 2.16.6 release.

1 Like

Thanks. Until then, will try another project :slight_smile:

It’s in the store now.

1 Like

My mistake: easy smile: I understand it “is not yet updated”
I update the app and it looks like it works. I make some tests and write down my conclusion.
Thank you for answers.

1 Like

Works fine in Android version (2.16.6). I use just digital outputs, D0 on “Time” event and D1 on “When” event (sensor reading ). I added 6 “Time” events for 3 operating time, and it is ok, work fine.

I use in same time iphone, (Blynk version 2.11.2 (0)), and still is problem whit sync button triggered by “Time” (D0)
Button D1 trigerred by sensor, works and sync well in ios (no problem)

1 Like

Sounds strange. Could you reproduce both (synced D1 and not synced D0) and right after send me the logs from your iPhone?

sorry, novice, how coud i do this?

edit: i found,…
edit: send

Got it, thanks.
Your D0 and D1 buttons has min-max settings set to 1023-0
Did you manualy set it so?

Yes, maual set. If is 0-1023, relay stay powered at startup, in “stand-by” mode for my application. Period when heating is off is greater then heating time, so relay must be unpowered

I chose 1023 value instead 1 or ON, because of many tests doing for good result

OK, thanks for clarification.

I seem to have found the issue. We’ll fix in the upcoming udate.


I made some test, for project above.
It is work well on Android tablet, Android phone and iphone. All version is updated.

If login separately, all it is ok.

If I login on Android and iphone in the same thime, things is changing. The sync is not good , alternativ Android / iphone… I think the problem is logon multi devices at the same time whit same account (Android + IOS). With 2x Android is ok.

I “cloned” project made on Android, on iphone, but on Iphone apear “Device is ofline”. How work “Clone”?