[SOLVED] ESP8266 local server issue

I am having trouble with my local blynk server. I can’t get my ESP8266 to connect. I am using the blynk demo and can connect to the blynk server, but not to my raspberry pi server. I can see that the ESP8266 is connecting to the wi-fi, but it never shows as connected when I watch from the server administration browser and it shows as disconnected on the app. I can see the app has connected to the server, and have checked the authentication token several times to ensure it is correct. I believe the error is somewhere in my server setup, but I am not sure where to start looking. I have been through the log, but have not seen anything. Unfortunately I am having trouble getting the log off the raspberry pi. Code I’m uploading via Arduino is below. Pretty sure it doesn’t matter but the ESP8266 is the Adafruit version.

  Download latest Blynk library here:

  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.

    Downloads, docs, tutorials:
    Sketch generator: 
    Blynk community:  
    Follow us:        

  Blynk library is licensed under MIT license
  This example code is in public domain.


  You’ll need:
   - Blynk App (download from AppStore or Google Play)
   - ESP8266 board
   - Decide how to connect to Blynk
     (USB, Ethernet, Wi-Fi, Bluetooth, ...)

  There is a bunch of great example sketches included to show you how to get
  started. Think of them as LEGO bricks  and combine them as you wish.
  For example, take the Ethernet Shield sketch and combine it with the
  Servo example, or choose a USB sketch and add a code from SendData

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "65796dd4eb374.......84d74f433f89";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "wifi";
char pass[] = "password";

void setup()
  // Debug console

  //Blynk.begin(auth, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, ssid, pass, "", 8442);
  Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,191), 8442);

void loop()
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!

Firstly, I had to edit your post to correct the posted code for proper viewing, as shown in the Forum’s Welcome Topic…

Next, hopefully you are aware that the Cloud Server and your Local Server are completely separate Servers…

So in order to switch between them, you need to log into the respective server, with it’s respective project (that you created while logged into said server) and dedicated Auth code (that is generated by the respective server) for use in the paired App/Sketch.

Thank you for fixing it. I apologize. I’ll read the new member stuff.

I do know they are different and am switching between the protocols both on the app and on the esp8266. I have the server running and am able to enter the admin screen. I have changed the app to address the server via IP address and can see that it is connecting via the admin screen as well. I see that the esp8266 is connected to my router and is getting an IP address, but it never connects. I am watching for connection both on the admin screen and on the app. My log files looks identical to ones I looked up that have moderator comments saying they look correct.

Thanks again for helping my post.

OK, so you have successfully connected everything via the Cloud server and are now testing your Local Server.

After creating a new account on your server, then creating a new project, you would have received a new auth code. Is that is the one you are using in your current sketch?

Also, do you have your ESP hooked up to the USB on your PC? If so can you see and show us what is happening on the IDE Serial Monitor.


Thanks for the help. The serial monitor showed it was a bad authentication token. I couldn’t figure out the discrepancy with the token, so I refreshed the token on the Blynk app. New the new authentication token worked perfect.

Thanks again,