[SOLVED] Connection trouble to blynkup with esp8266 esp01

Congratulations for your platform! I have some issues though.
I use the blink example https://examples.blynk.cc/?board=Arduino%20Uno&shield=ESP8266%20WiFi%20Shield&example=GettingStarted%2FBlynkBlink
in the arduino nano, with the esp8266 esp01 and i have this issue; i upload this code and the arduino connects to my wifi network, but it cannot connect to blynk. is there a solution for that?

the code that i used

  Download latest Blynk library here:

  Blynk is a platform with iOS and Android apps to control
  Arduino, Raspberry Pi and the likes over the Internet.
  You can easily build graphic interfaces for all your
  projects by simply dragging and dropping widgets.

    Downloads, docs, tutorials: http://www.blynk.cc
    Sketch generator:           http://examples.blynk.cc
    Blynk community:            http://community.blynk.cc
    Follow us:                  http://www.fb.com/blynkapp

  Blynk library is licensed under MIT license
  This example code is in public domain.

    It's rather tricky to get it working, please read this article:

  You’ll need:
   - Blynk App (download from AppStore or Google Play)
   - Arduino Uno board
   - Decide how to connect to Blynk
     (USB, Ethernet, Wi-Fi, Bluetooth, ...)

  There is a bunch of great example sketches included to show you how to get
  started. Think of them as LEGO bricks  and combine them as you wish.
  For example, take the Ethernet Shield sketch and combine it with the
  Servo example, or choose a USB sketch and add a code from SendData

/* Comment this out to disable prints and save space */
#define BLYNK_PRINT Serial

#include <ESP8266_Lib.h>
#include <BlynkSimpleShieldEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "97175df40818441db1431c48dbdde088";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "Xaratsi";
char pass[] = "xxxxxxxxxxx";

// Hardware Serial on Mega, Leonardo, Micro...
//#define EspSerial Serial1

// or Software Serial on Uno, Nano...
#include <SoftwareSerial.h>
SoftwareSerial EspSerial(2, 3); // RX, TX

// Your ESP8266 baud rate:
#define ESP8266_BAUD 9600

ESP8266 wifi(&EspSerial);

void setup()
  // Debug console

  // Set ESP8266 baud rate

  Blynk.begin(auth, wifi, ssid, pass);
  // You can also specify server:
  //Blynk.begin(auth, wifi, ssid, pass, "blynk-cloud.com", 8442);
  //Blynk.begin(auth, wifi, ssid, pass, IPAddress(192,168,1,100), 8442);

void loop()
  // You can inject your own code or combine it with other sketches.
  // Check other examples on how to communicate with Blynk. Remember
  // to avoid delay() function!

in this photo shows my circuit, the esp01 is fed with 5V and is regulated through the adater that is shon in the picture.

in the serial monitor only this is printed, and it’s seen that it has the flash that refers to the docs.

in this picture appears that the circuit is not connected to the blynk , although I use the same authorative.

Thank you in advance

You need the correct current too, not just voltage and the recommendation is that you will not get enough current from an Arduino to run an ESP (especially the basic 01). Arduino’s will provide enough power to flash an ESP but not enough to run WiFi etc after flashing.

There are 10+ other reasons why your system might not work but at least you seem to have the sketch set up correctly.

Thank you Costa for your quick reply.
I tried with two different ways to feed the esp 01

  1. I fed the adapter direct from usb on my computer
  2. I also fed the adapter direct from my usb phone charger with 2 Amps ability

The problem wasn,t solved

I think my adapter has build in a ams1117

my adapter with the esp it is below;

I have several of those and they are not wired up for flashing, just for running.

And what do you advise me to do, to we will find a solution?

You need to solder a wire across 2 of the pins. Google has the answer.

You mean to run the esp in flashing mode?
but this mode it isn’t only for to write a new firmware in esp?

Yes you are right for shield, IF the baud of the ESP has come from the factory at 9600 you will not need to flash it. Unfortunately many come at 74800 or 115200.

My esp came with 115200 baund but i flashed it and i uploaded this;
AT version: 11 2016 18:09:56)
SDK version:1.5.4(baaeaebb)

Which the blynk recommends us.
And after this i changed the baund into 9600 with this command ; AT+UART_DEF=9600,8,1,0,0

Now i deal with this problem and i can’t find a solution.

And something else Costas, are you from Greece or Cyprus?

I live in Cyprus.

Seriously? (Εγώ μένω Ελλάδα Θεσσαλονίκη😀)

There is a case to blame the firmware?

Ok guys the problem solved when I change the AT firmware.
Thanks for your help.

1 Like

A post was split to a new topic: ESP-01 firmware