[Solved] Bug: Time Input on Android reverts to AM if hour is changed


  1. Add time input to project. Enable AM/PM format.
    1a. I also enabled days, sunset, sunrise, but those may not be relevant.
  2. Run project, tap time input, and tap the [Start At] dropdown.
  3. Select any time of day after noon (e.g. 1pm).
  4. Tap [ok] and [ok] so you’re back to the project screen with your time input correctly showing “1:00 PM”.
  5. Tap time input again, and tap the [start at] dropdown.
  6. change just the hour to 2, and note that the input still indicates “PM”.
  7. Now tap [ok].
    Expected: the input should read “2:00 PM”.
    Actual: the input now reads “2:00 AM”.

The problem doesn’t appear to happen if you change only the minutes.
App version 2.14.6

1 Like

there is new app version, 2.15.2, please update and check again!

With TZ bug :slight_smile:

sorry, the op stated he uses 2.14.6
i didn’t knew it is still present in latest.

Not sure it’s the same issue but I wouldn’t go to 2.15.2 as TZ appears to fail altogether.

i updated because i needed some background notification bug fixes and other stuff. i do not use the time input widget, so i don’t know.

Bit like saying there are bugs in XP.

That’s kind of unfair. It’s not like 2.14.6 is superseded by multiple major releases spanning a decade. That version was the latest maybe 6 weeks ago. In any case, you indicated yourself that you would not update 2.15.2, so what do you suggest?

I did the update before I knew 2.15.2 was problematic, and now–in addition to the original problem that still occurs–I have even more issues to deal with. This is why some people avoid hasty upgrades.

Wait for the fix.

OK, how do I downgrade back to 2.14.6, or some other version?

We are working on a fix, if everything will be ok, we’ll release it tomorrow or on friday

Seems your issue reproduces only in the case of enabled sunset/sunrise support

Sent the procedure to you via PM.

@costas, can you also send me the info on how to downgrade to the previous version? I hit the time input bug as well. TIA.

Blynk have now released the fix in a logging build at Automatic scheduler. ESP-01 with 4 Time Input Widgets

Just to confirm this build fixes the timezone but I don’t know about the AM / PM issue. I’ll try and check.

Edit: following the instructions in the OP it looks like the logging build also fixed the AM / PM issue. It works on my Android but my underlying time settings are 24 hour clock but set as AM / PM in Time Input.

Can @BlynkSky confirm the fix on their phone.

1 Like

AM/PM issue should also be fixed

1 Like

Marked as issue solved unless anyone knows different.

APK won’t install. Doesn’t give a reason. I enabled “unknown sources”, but it just fails to install.

Backup your existing apk, remove Blynk and try again to install the logging build.

if you try to install directly from the dropbox app, it won’t install without any reason. you should open the file manager on the phone, navigate to downloads folder and try to run from there. it is the same on my phone, i do not know why.