[SOLVED] Blynk doesn't work with Esp8266-01


I’ve tried with many Esp8266-01 (by bangood) but up to now i was not able to have any connection with Blynk using the simplest Standalone example.
No problem with CC3000.
May someone give me some suggestion?

Can you tell us what isn’t working? Is there any output on the serial console?

No output on serial console. Note that i use normally esp with ApiRest without problem so i’m sure that my esp works. I’ve tried to compile the sketch with different setup.

How do you connect your ESP and does the sketch upload OK? Is there any errors in the IDE when you upload? Please provide some more information, thanks :wink:

Hi, first of all thank you for your help.
No error in IDE after compilation. I’ve used two set up:

Olimex MOD-Wifi and Generic ESP8266 Module

No blue led blinking on Esp8266.

I wonder there is some wrong on set-up parameters or my Esp is not compatible with Blynk library.

Most ESP’s work fine with Blynk. Does the sketch upload OK?

Yet The sketch Was uploaded without faults. I’l try with Esp8266-07.

And the wiring is OK? A running ESP should, as far as I know, have CH_PD also HIGH. Otherwise it won’t work.

Yes I’m sure about wiring bacause I use the same module with aRest api without problem.
I’m afraid my module is not compatible with Blynk library…

Hi, what about reflashing the ESP?

Hi psoro, thank you good idea. I’ve never flashed Esp8266. I’ll look for the procedure and I’ll try.

http://reflowster.com/blog/2015/05/11/esp8266.html This is a good starting point. It helped me very much.

It still is weird it doesn’t work. It shouldn’t have to do with firmware, but it could help.

On mine, there is no blue blinking… but it’s working.
for serial output, check speed, it must mach the speed in your script.

@Lichtsignaal what AT firmware version is working best for you (and link?)?

This one seems to be stable:


http://www.xess.com/blog/esp8266-reflash/ (comes from this guide, also very nifty!)

I think there is a 0.9.5 firmware too somewhere.

The firmware I use is this one (AI-v0.9.5.0 AT Firmware)

Will this firmware work with an esp12?

Edit: finding out now… :grin:

I would suggest using official Espressif AT firmware if you want to use it in first place anyway.



Again thank very much to everyone helps me with suggestions.

I’ve tried with my esp8266-07 (by Bangood) without problem and Blynk works very well.

I’ve used :

Node MCU 0.9 (ESP12 Module), 80MHz, 115200 bds and a 0.1uF capacitor between + -.

With esp8266-01 I’ve tried to re-flash with firmware you’ve suggested to me but without success. I’m afraid there is somethings wrong (hardware?) with my module. So I’ve ordered another one and I’ll try again.

Of corse I’ll give you feedback.:stuck_out_tongue_winking_eye:

Hi again, just a silly question… Did you put GPIO0 to LOW while flashing?
I can share with you the flasher I use… Let me know