[SOLVED] Blynk app (android) couldn't connect to the server

Android Blynk app wont open

I’m having issue with blynk app on my android device.
“Couldn’t connect to the server. Please check your internet connection, or try again.”

Is anyone else haveing the same problem?

1 Like

Server “can’t talk now” since early morning. Can’t log in.

I’m in the same boat now (cloud). Trying to sign in with username and pw on Android and getting “Something went wrong when connecting to the server. Please try again later.”

Oddly enough, even when logged out of the app I can still send myself a notification through the API POST!

Is issue still there? If so please try reboot phone/router.

It’s working ok now. Thank you for your time & work.

Hi all , still Android App not able to connect to server, i tyied with re-install & Android phone reboot…nothing!. Everthing else (internet connectivity related) work as expected! on a Samsung S3 ?? Does anyone have any idea?
(Hardware Arduino UNO+Ethernet shield seems that is normally connected to blynk-cloud.com)

1 Like

@andromedas please logout and try login again. What error message do you see?

Hi, i tryied to log out and then login but it acts like no internet connectivity at all allthought everything else is working as expected!
(the error as the above photo)

@andromedas sorry, didn’t understand you. On login screen should get a bit different exception. Could you please tell what exactly it is. It may help.

" Something went wrong when connecting to the server.Please try again later "

@andromedas are you within some local network or 3g?

i tryied through local WiFi and mobile network with no luck (me and a friend from another location with his mobile) (is something that has to do with Greece? DNS Server update?)

Probably yes. But I don’t know why it takes so long. As an option you may try changing DNS server on your local router to google DNS instead of DNS of your local provider.

but… mobile? why (can’t change provider DNS server!)

i saw a Blynk user named @Costas (brobably he is in Greece or know something about it)

SOLVED! I uninstall Blynk app > reboot > re-install app > All Good! @Dmitriy thanks for your time.

@andromedas hm interesting… Look like Android caches domain names somehow-somewhere.

The ‘Greek’ island of Cyprus that is not Greek.

We just rebooted our router and our Samsung S3 connected first time.

1 Like

Greetings to beautiful Cyprus! i love this Island and its people! :slight_smile: Happy coding.


I have same problem

@moh this is a 5 year old topic, lots of things have changed since then!

Have you read this recent announcement?..