[SOLVED] Blynk and Arduino 101 with BLE (beta)


I’m trying to use Blynk with Arduino 101 and BLE. I know BLE is still in beta.

Am I doing something wrong? Is there a debug trace I can send you?

Thank you

Where is your BLE widget?

Thanks for the hint!

It works now.

One more thing:

I’ve added a timer which sends a calculated value every second

timer.setInterval(1000L, sendUptime);

It works fine for a while…

[62752] <[14|00]=[00|0B]vw[00]0[00]29.277
[63468] >[14|00|1D|00|04]
[63491] >vr[00]0
[63752] <[14|00]>[00|0B]vw[00]0[00]29.277
[64468] >[14|00|1E|00|04]
[64490] >vr[00]0

…but then the timer is ignored and updates are sent 10 times faster every 100 ms.

[76405] <[14|00]L[00|0B]vw[00]0[00]30.566
[76518] <[14|00]M[00|0B]vw[00]0[00]30.566
[76618] <[14|00]N[00|0B]vw[00]0[00]30.566
[76718] <[14|00]O[00|0B]vw[00]0[00]30.566
[76818] <[14|00]P[00|0B]vw[00]0[00]30.566
[76918] <[14|00]Q[00|0B]vw[00]0[00]30.566
[77068] <[14|00]R[00|0B]vw[00]0[00]30.566
[77168] <[14|00]S[00|0B]vw[00]0[00]30.244
[77270] <[14|00]T[00|0B]vw[00]0[00]30.244
[77368] >[14|00]*[00|04]
[77390] >vr[00]0
[77405] <[14|00]U[00|0B]vw[00]0[00]30.244
[77518] <[14|00]V[00|0B]vw[00]0[00]29.600
[77618] <[14|00]W[00|0B]vw[00]0[00]30.244
[77718] <[14|00]X[00|0B]vw[00]0[00]29.922
[77818] <[14|00]Y[00|0B]vw[00]0[00]29.922
[77918] <[14|00]Z[00|0B]vw[00]0[00]29.922
[78018] <[14|00][[00|0B]vw[00]0[00]29.922
[78118] <[14|00][00|0B]vw[00]0[00]29.922
[78218] <[14|00]][00|0B]vw[00]0[00]29.922
[78370] <[14|00][1]vw[00]0[00]29.922
[78468] >[14|00]+[00|04]
[78490] >vr[00]0

Trace is provided by debugging activated with #define BLYNK_DEBUG.

  1. 00|0B ↩︎

Hm… this looks like a bug in SimpleTimer.
But it doesn’t happen on other platforms.

@Avenue33: looks related to this bug in Arduino 101, I reported recently: https://github.com/01org/corelibs-arduino101/issues/190

Great! Thank you for the update.