Serial monitor constantly saying "Connecting to"

Serial monitor constantly saying “Connecting to
I’ve tryed restarting my router, using the manual example and changing ethernet cables.
My arduino ethernet shield is connected into a homeplug via a Ethernet cable.
It does not even get as far as checking my auth code.
I’ve had to take out all links but the important ones due to the fact that I am a new user.
My sketch is:


  • Blynk is a platform with iOS and Android apps to control
  • Arduino, Raspberry Pi and the likes over the Internet.
  • You can easily build graphic interfaces for all your
  • projects by simply dragging and dropping widgets.
  • Downloads, docs, tutorials:
  • Blynk community:
  • Social networks:
  •                            *
  • Blynk library is licensed under MIT license
  • This example code is in public domain.

  • This example shows how to configure static IP with Ethernet.
  • Be sure to check ordinary Ethernet example first!!!
  • NOTE: Pins 10, 11, 12 and 13 are reserved for Ethernet module.
  •   DON'T use them in your sketch directly!
  • WARNING: If you have an SD card, you may need to disable it
  •   by setting pin 4 to HIGH. Read more here:


#define BLYNK_PRINT Serial // Comment this out to disable prints and save space
#include <SPI.h>
#include <Ethernet.h>
#include <BlynkSimpleEthernet.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = “CENSORED”;

IPAddress server_ip (46, 101, 143, 255);

// Mac address should be different for each device in your LAN
byte arduino_mac[] = { 0xDE, 0xED, 0xBA, 0xFE, 0xFE, 0xED };
IPAddress arduino_ip ( 192, 168, 1, 120);
IPAddress dns_ip ( 192, 168, 1, 254);
IPAddress gateway_ip ( 192, 168, 1, 254);
IPAddress subnet_mask(255, 255, 255, 0);

void setup()
//Blynk.begin(auth, server_ip, 8442, arduino_ip, dns_ip, gateway_ip, subnet_mask, arduino_mac);
// Or like this:
Blynk.begin(auth, “”, 8442, arduino_ip, dns_ip, gateway_ip, subnet_mask, arduino_mac);

void loop()

Thanks for reading!

  • DejaVu

Forgot to say, My hardware is an Arduino UNO and a generic Ethernet shield from amazon.

Please follow blynk troubleshooting guide, and report where the problem appears.

Hello, why are you specifying what server to connect to? Let the blynk library do all of it and use dhcp. Try that see if it works.


Best Regards :slight_smile:

@FunguyPro I’ve used the default example and then got a Failed to get IP: DHCP failed or similar.
@vshymanskyy I’ve already looked at that and I used telnet, I got an error, “Could not connect to host.”

  • DejaVu

@DejaVu, is your network setup with dhcp? Also, what shield are you using?

@FunguyPro I’m using a Ethernet shield by a company called “HanRun” and the model number is (i think) “HR911105A”
and I do not know if my network is setup with DHCP. (my ISP is PlusNet if you wanted to know)

@DejaVu Ok the wifi shield is a well known company and does work totally fine with blynk, do you have wifi with your network? If so then it probably does have DHCP and the problem is some where else. Also, do you have the latest library?

@FunguyPro I have wifi yes, I don’t know where the problem is, but I am using a TP-Link Homeplug (Ethernet though your power sockets) to connect to my Arduino, I will try connecting It straight to the router if you want.

@FunguyPro And yes, I have the latest libraries.

@DejaVu , try connecting straight to the router. See if that works.

@FunguyPro Okay, will do

This means, blynk server is not visible from your network. the server might be blocked by your ISP.
Is this your home network? What country are you from?

I’m having similar problems, but I can ping the server and get 100% response success. I’m upgraded to the latest library, and have followed the coding suggestions in this thread.

Pinging is not enough. Most common problem is closed ports. Please try telnet command.

I tried putty, but application quit before giving me any indication of success or failure! I’ve checked my router settings, and I’ve setup my ESP8266 under port forwarding tab for ‘Remote Anything’ applications. Maybe this is a problem (as I’ve had it working before port forwarding was setup). However, it also seams like a likely solution to closed ports.

Putty is not really working for this. You need to enable telnet client (assuming you use windows) and try that with a cmd window open.

Forwarding is NOT a solution for closed port! Forwarding is only needed if you want to make a device on your local network accessible for the outside world. It’s better not to mess with it if you don’t know exactly what you are doing.

Setting up telnet in Windows Vista never finishes installing through program features of control panel, and I can’t find it in windows 10

Why not ask Google to do it for you.

SERP #1 gives How to enable the telnet client in Windows 10

Got to be worth a try, no?

Google is a search engine that has an answer, not always the correct answer, to every question you have.

Worked on my windows 10 machine.

Microsoft Windows [Version 10.0.14393]
© 2016 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>dism /online /Enable-Feature /FeatureName:TelnetClient

Deployment Image Servicing and Management tool
Version: 10.0.14393.0

Image Version: 10.0.14393.0

Enabling feature(s)
The operation completed successfully.