Raspberry Pi B+ is offline (Using WireingPi)

I installed blynk on my Raspberry Pi B+(stretch) connected my iphone. However, it sometimes works and sometimes not. My iphone app. shows “raspberry pi is offline”. Once this “offline” message appears, I need to restart blynk on my Raspberry Pi. Anybody experienced similar case? How this could be solved? Below is what I see on my raspberry pi.

v0.5.0-beta on Linux
[5001] Connecting to
[10271] Ready (ping: 72ms).

Kinda like asking if anyone has ever had a headache and why :stuck_out_tongue_winking_eye: Soooo many reasons for your device to be offline.

First, revert back to the stable Library… v0.4.10 then confirm you are not experiencing errors in your code that cause the thread to crash (watch your CLI for any messages).

Since you appear to be using WiringPi, I do not know what other traps there may be, but you can also post the code you have written here, to let others check it out for any obvious issues.

Please format any posted code as per the Welcome Topic…

have you open all the readme files in the blynk library folder??
I managed to solve my connection problem after i found something that i didn’t do.
i ran this on the command prompt and i have no more connection problem.
./ raspberry

1 Like

It didn’t work for me…

Thanks for the tipcs. (I think) I installed v0.4.10 library but my raspberry still shows v0.5.0. Is there any way to remove v0.5.0 and install v0.4.10 from the beginning?

Sorry, but while I did try to use it earlier in the year, I don’t use the WiringPi method anymore with Blynk & RPi, so I am not precisely sure… How did you install the 0.5.0 version? Look for wherever it installed to and delete that directory and try again?