QR Codes issue (older Local Server, newer App)

Hi, I’ve an issue with QR Codes. I already use them from a lot of time in order to share access to my projects with other people.

Now the problem is this: within the same login account I have realized three projects and have shared the relevant QR Codes. But only the first works, the other two doesn’t work both with iOS and Android. Of course the projects are running and there is plenty of energy.
The answer on iOS is: “Can’t load project” (in red)
The answer in Android is: “Couldn’t connect to the server. Please check the internet connection” and then “xxx app is no longer available, sorry”

Of course the internet connection is ok and the app is available.

I precise too that I have already realized many projects within the same login account each with its QR code and everything worked fine.

I work with the last version of Blynk both on iOS and Android and use a local server. Maybe the issue could be linked to the last update of Blynk app?

Do you have ani idea ?


Hello. This is “sharing” QRs and not clone QRs, right? Do you scan them from login screen?

Yes I confirm that it’s a sharing NOT cloning. I scan it from login screen as I do always with all other codes

I’ve read the QR Code with a QR Code reader and they appear correct with the sam format of the working QR code

Ok. Thanks. We’ll check.

Please, find reported what I read from the QR codes. The first is working, the second isn’t:

blynk://token/projpriv/23c0e24beb85453786c4d49180d7d934?username=ms.torres@gmail.com&server= di Torres 1

blynk://token/projpriv/8f657958fc5447b28b4f9d89eb37c232?username=ms.torres@gmail.com&server= di Torres 2

Thanks, Giancarlo

@Gianca do you use URL for opening or QR?

@Dmitriy Sorry, not sure to understand. I have opened the QR Code with an app called QR Reader. With Blynk I scan the QR code in the usual way.

@Dmitriy May I send you the QR Codes ?

@Gianca do you have latest server?

I use the last version of Blynk app but I’m forced to work with an old version of the server for the problem of raw files. Do u remember? But consider that the last working QR Codes was created no more than 2 weeks ago.

You need to use latest server version. Otherwise this is expected.

So I’ve lost QR Code function too ! Great!

What do you mean?

If you have need to stay with an older version of server, then you also need to avoid upgrading the App and Library as well, otherwise the current progress the developers are working on in newer components will eventually conflict with older components.

Backward compatibility can only go so far before it becomes an anchor.

I guess you can try Googling for an older version of the App APK to revert to and some of the older libraries are still available here:

Or just embrace the update and change how you use data in the newer Server.

1 Like

I’m sharing my project (not clone) - running on my local server on RPI - and after a while is not working on the shared side: when I scan the code is loading…and loading and nothing is happening; first time when this happened I have regenerated the QR code and worked; then, when it didn’t work again, I checked and compared the 2 QR codes and observed the IP of servers was different (I’m using a DDNS to connect to master project). Is my assumption correct - the reason for shared project not working? if yes, is there a solution to this? for ex QR code to contain the DNS / DDNS and not the IP (numeric format eg: 86.127.186.xxx). thx

What app are you using for share QR generation - Android or iOs?

Android on Samsung S7, latest version of Blynk app.

1 Like

Yep, seems it is connected to an old fix, we’ll change that in 2.18.0 release, that should be available till the end of the following week.

Do you set up a domain name and not an IP address to connect to your server?