BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

Provisioning Issue Android

I’ve been testing some devices using dynamic provisioning and recently the “automatic” wifi connection doesn’t seem to work. When adding a device there is a pop-up where you choose the device “Blynk ****”. When this is chosen the connection doesn’t seem to happen. If I go back and use the “manual” method to select the device from the phones list of wifi networks it connects quickly and provisioning works no problem.

Using Pixel 6, Android obviously.

Just curious if anyone else has seen this issue recently.

Are your steps:

  1. Actions Menu
  2. Add new device
  3. Connect to Wi-Fi
  4. tap Ready
  5. select a Device from the list
  6. follow and complete Device provision?

What’s your device Android version and could you please provide us logs?

@BlynkAndroidDev FYI

What type of device are you provisioning?
What version of the Blynk library are you using?
Is your sketch based on an old version of the Edgent example sketch, or the latest one from the GitHub page?

Pete.

Which Android OS version is on your Pixel?

There was a similar bug in Android 10 (I believe you are at least on 12L or 13 beta?), it does not allow you to connect several times during provisioning to the same hardware, usually, after a phone reboot, it worked fine again (I believe Google has not fixed it in Android 10, but I had not seen it in 11-12L ones).

I wasn’t expecting so many replies haha. I’ll try to answer the questions. @MarkPan @BlynkAndroidDev @PeteKnight

Actions>Add new device>wait for popup to show device>wait for device to connect>it doesn’t after X amount of time. So I then click cancel>click manual>choose device from phones wifi list>back to blynk app>device connects quickly and everything else is fine.

It’s an ESP32-S2-SOLO (custom board). I’m not sure about Edgent level as I didn’t personally write the firmware. However it was working without an issue before, this issue is new.

Android 12 (doesn’t say L so I’m assuming it’s not)

And yes I can send the logs, what e-mail do I send them too? I’ve been testing a number of things so there might be a bit to dig through, although I’m sure you know what you’re looking for.

If it is on the latest android 12 - it is 12L. my Pixel 3a is not showing any 12L, no 12.1 as well. Thanks, I will try to check with the latest update on my device if it reproduces.

OK great. Let me know if you need anything.

If location permission is now allowed - please retry with it allowed - will it change anything. It should not require location permission, but it seems on my device it is working only with location permission.

I am not near a device to try right now, but I did check my settings and the Blynk app already has location permission “allow only when using the app”

1 Like

Also can you send logs from the app: Main Screen → Left Menu → About → Send logs → Select Gmail - it should set up email and attach a file with logs

OK just sent them. Thanks!

Were the logs received/looked at? I just tried “reconfiguring” a different device, similar but different firmware, and it had the same issue.

Our QA team is investigating the issue, if you will have it again - please send logs right after the failure of provisioning.

In a week or two, there will be a new version with some updates in the provisioning.

I have a Pixel 5a5g Android 12 and encountered a similar problem trying to wifi provision my devices. I finally disabled the Cellular data connection, leaving wifi on, and immediately connected to the device. Maybe something to try?

1 Like

Sounds good! No customers have mentioned it, so it is probably Android only, and perhaps just the version/phone mix. I will send logs right away if/when needed. Please let us know when there is an update to the app. Thanks!

@xt36md very strange. I have found using the “manual” connection works fine.

1 Like

wow, that’s strange, has it been the same issue with problems in the wifi points list screen?

We added manual connection when we learned about similar issue on Android 10: re-provisioning of same hardware for 2-3 times leads to stuck in the wi-fi points search screen (seems some android 10 bug). So with manual connection you will always be able to connect to hardware, or at least have 2 options to do that)

I mean this COULD have been the issue I’ve seen because I only had test hardware and perhaps I re-provisioned it multiple times. I don’t remember at this point, and I am all out of hardware to test right now. Anyway, as I mentioned no customer complaints so it’s not an emergency (yet lol).

1 Like

I just wanted to update. I just received new boards, I uploaded firmware as before, tried to connect on Android, and the same issue occurred. When using the “manual” option it connected fine as before. I sent the logs as soon after the issue as possible this time. If you need anymore info please let me know.

1 Like