BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Problems scanning QR code on Android

Hi there,

I’m still having this same problem with the latest version on Samsung Galaxy S5.

Any advice or updates?

Also, I was curious: what does the icon on the top-right of the QR scanner screen do? It’s not present on the iOS version, and it doesn’t seem to have any impact.

Thanks very much–great project!

You posted on an old topic that has had it’s issue resolved with focusing adjustment (that is the icon you are seeing… it may enable/disable auto focusing… depending on your phone), so your undefined issue is not necessarily “the same”.

I have moved you into your own current topic.

Please supply details on exactly what you are trying scan i.e. where is the QR from? Have you tried others? (And they must be Blynk QR codes to work) and what the resultant issue is, including error msgs, if any.

If issue still appears to be focus… then try stabilising the phone (hand shake will cause issues) and manually moving the phone back and forth until clear?

Thank you.

Thanks for the quick reply!

The QR code is indeed one generated by Blynk, from my iPhone 5S. I have successfully shared it with a few friends already, two on iOS (iPhone 5S & 6), and one on Android (Google Pixel).

However, another friend with a Samsung Galaxy S5 has been unable to scan it. There is no error message or any indication that anything is wrong–the app simply does not acknowledge the code. The image when we try to scan is well lit and very sharp, and the phone was not shaky, and we have tried varying the distance from the phone to the code as well.

I have not tried generating a different QR code within Blynk, as this is the only app I have built so far, and I wasn’t sure if re-generating the code for the same app would impact the access I have already given to my other friends.

I wish I had more diagnostic info to provide, but that’s all I’m able to observe–the scanner just acts as if it does not see a QR code in view.

Thanks for your help.

@somaholiday I have an S3 that sometimes fails to recognise QR codes. In my case it seems to be a lack of memory on the S3. Ask the S5 user to reboot the phone and try the QR code before all their other apps start using memory.

Actually my wife has an S5 if you want to PM the code to me to try.

3 Likes

@Costas, thanks for the tip! I’ll give it a try and post back here if it works. Thanks for the offer of trying it yourself, as well–unfortunately there are security concerns with sharing this particular app.

@Costas, gave rebooting a shot, and still no luck. The phone tells us “Active applications: 0”, RAM status 0.99GB / 1.67GB. We also tried uninstalling and reinstalling Blynk, which didn’t help. Also checked if there are updates to the phone OS, but it says it’s up-to-date.

@somaholiday did the other people use the QR code at broadly the same time as I believe the codes have a validity period. Not valid for X number of days but valid for so many revisions of the Blynk app.

I am also having this problem. Android S6. Tried scanning on screen, TV, paper, nothing works. I can in fact scan the code with “Lightning QR Scanner” no problem. It appears to be an issue with the Blynk app. It is the latest version as of this writing.

OK I just got it to work (figures, as soon as I post) and here’s how:

On the scan screen in Blynk, I did a “pinch to zoom” and the image got larger. I then had to back away so that the code would all fit in the frame and boom – it worked. Hope this helps someone.

Yes, that is another way of triggering the focus on the phone… Good catch.

I know this is an old thread but I just tried to scan a QR code (for OpenGarage) on two android devices and it would not scan.
I installed the Blynk app on my wife’s iPhone and it worked straight away.