Problem with Numeric Input Widget - BLYNK IoT

I’m migrating my existing Blynk IoT ESP8266 project to ESP32.

I was able to copy all the template configuration on the web console in order to avoid the need of creating the same list of datastream.

It wasn’t possible to copy the mobile dashboard too, and I’m now trying to copy manually the design doing everything again.

But with the numeric input widget I can’t configure the step to 0.1 as it was in the ESP8266 version. I need the value looping as 0.1 - 0.2 - 0.3 - 0.4 …

Any hints?

I’m not clear why you’re doing this if the project is basically the same but you’ve just changed the hardware type.

Maybe I’ve misunderstood the issue?


Hi @PeteKnight

I already have some ESP8266 devices working with my aquarium doser project.

Following your suggestion I’m testing using ESP32 dual core in order to run blynk in a second core to avoid blocking the device process.

When you create a template, you have to chose the device hardware. This allow you to use all the ESP32 I/O and features.

And, because it is no possible to copy the mobile dashboard, I started creating a new one, an exact copy of the one already working with ESP8266.

But, when I create the numeric input widget, It was no possible to set up the increment, as was possible a few weeks ago. May be it’s a feature that was changed in a very new version of the mobile app. I don’t know.

In my experience this makes absolutely no difference, and would only make a difference if you were using digital or analog pins as opposed to virtual pins…

This option isn’t just available at template creation, you can edit it too.

So it seems to me that you’re doing a lot of work for no reason.


Thinking deeply, you are right. The only reason to create a new template for using the ESP32 would be if you want to activate the additional GPIO ESP32 provides (a lot more than the one availables por ESP8266). I’m doing more work than necessary as you says.

But the question about you cannot chose the increment in the Numeric Input widget remains.

As you can see in the attached pictures, it looks like you can´t choose the size of the increment.

I can’t find a way to change the Step

Looks like it’s related to this issue with the Android app…

But if you read the link I provided, you’ll see that this doesn’t actually make any difference.


1 Like

I’m sorry Pete, I forgot to mention the reason about to agree with you about the lot of work for nothing. I readed the link you posted.