Problem with connecting the HC-08 BLE module to the blynk app

I have a problem with connecting the HC-08 BLE module to the blynk app. I have tried the troubleshooting suggestions listed in the BLE article and other forums, but I seem to still have the same error message: “Connecting… Can’t connect." Does anyone have any other suggestions? I have included my code down below.

Blynk Version: v0.6.1
Board: Arduino Uno
Device: Iphone ios

#define BLYNK_PRINT Serial

#include <SoftwareSerial.h>
SoftwareSerial SwSerial(11, 12); // RX, TX

#include <BlynkSimpleSerialBLE.h>
#include <SoftwareSerial.h>
#include <Servo.h>

char auth[] = “600339bb0e6b4bdfa2c17f3d0cb4d32e”;

//SoftwareSerial SerialBLE(11, 12); // RX, TX

Servo thumb;
Servo middlefinger;
Servo indexfinger;
Servo ringfinger;

void setup()

Blynk.begin(SwSerial, auth);

Serial.println(“Waiting for connections…”);

ringfinger.attach(3); // pinky + ringfinger

void loop()

Make sure you are running the Beta version of the iOS App.

Try using debug to see it your auth is getting broadcast… Also, if your posted code is any indication, I have seen strange results when the wrong type of “quote” marks are used in the IDE.

Hard to understand/explain how they change or why it matters to some, but for example > " < (from my KB) works while > < (copy/pasted from your post) usually doesn’t.

Thanks for the response. I checked all the quotation marks and they seem to be the " version. I have checked my auth by connecting over usb and wifi(which works). How do I check if the app is the Beta version on ios?

If you have to ask, then it is not :wink:

I updated to the newest version and now have Beta 2.26.0. The module seems like it’s about to connect but then it gives me the same error message. Any other suggestions? On the side note, I also saw that the BLE widget requires internet connection. Do I have to do something to ensure this? or it just means my iPhone has to be connected to wifi?

Aside from submit logging after the connection attempt, I don’t have any other ideas… but then I don’t use BT/BLE that much, and have not been able to get my only BLE device to connect to my iPhone either… although it works on Android.

Correct, as the App must have a Server link. The fact that the App lets you log in confirms such a link.