BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Problem PZEM-004T Version 3.0

#1

Hi Blynker.

I purchased this new version of the PZEM-004T, but I can’t get it to work with WEMOS D1 in any way, I can’t tell if the piece is broken. Someone who has been able to use it, could kindly help me to understand where the problem is.
Thank you so much .

0 Likes

How to use TASMOTA inside BLYNK and HOME ASSISTANT [Work in Progress]
#2

You tried YouTube?:wink:

0 Likes

#3


maybe you could try to connect to your computer using an USB converter or connect to rs232 port.

0 Likes

#4

Which version, and how are you connecting it?

Pete.

0 Likes

#5

There is a " 1k ohm Resistor " at the back of PZEM Module HERE (optional)

Details are in this link:

0 Likes

#6

I have already seen, but nothing to do on the internet show the. version 1.0.

0 Likes

#7

That guide is for the old version 1.0 I have V3.0 and different circuitry.

0 Likes

#8

I tried a USB-TTL converter but nothing works the same.

1 Like

#9

I’m using version 3.0, the one with white optocouplers.

0 Likes

#10

As the PZEM-004T expects 5V serial data and the WEMOS D1 mini only provides up to 3V3 the expected optocoupler input power of the PZEM-004T has to be reduced. This can be accomplished by soldering a 1k resistor between the joints shown below.

for that part v1 is like v3

Connect the serial interface of the WEMOS D1 mini with the serial interface of the PZEM-004T.

  • 3V3/5V Red
  • Rx Yellow
  • Tx Green
  • Gnd Grey
0 Likes

PZEM-004T v3.0 with WEMOS D1 not reading on Serial monitor
#11

I asked you which version of rage WEMOS D1 you are using, and how you are connecting it.

The D1 R1 is a very old board which has different pin designations to the D1 R2 and the D1 Mini is different again.

So, please say which version of the Wemos D1 you are using, ang how you are connecting it to the PZEM board.

Pete.

0 Likes

#12

if you’re computer doesn’t receive anything, your board is defective.

1 Like

#13

Still some hope exists, as it might be the serial bridge is faulty or wrong connected. Generally speaking I still own three of these boards and decided NOT to use them. I don’t like its design and found those (below) cheap (relatively) ready meters a better choice for three phase solutions.
2019-06-09

0 Likes

#14

I bought this one and I’m very happy.
it works like a charm.

0 Likes

#15

Using the WEMOS D1 Mini PRO, connecting: D7 + TX PZEM, D8 + RX PZEM. These are the links I make but nothing works, I don’t see anything in the serial window.

0 Likes

#16

if you don’t see anything on your computer with USB converter you can’t run your sketch anymore.

0 Likes

#17

to communicate
TX PZEM to ----> RX WEMOS D1 mini
RX PZEM to ----> TX WEMOS D1 mini

see picture

0 Likes

#18

Ok ok how do I set PIN as the code? (2,3)

0 Likes

#19

Well, this won’t work!
The D1 Mini/pro has one and a half UARTS.
UART0 is connected to he USB socket and also to pins Tx and Rx. And is used for programming the device.
UART1 is Tx only and is connected to pin D4.

If you need to have Tx/Rx communications with a peripheral such as the PZEM then you’ll need to use UART0. If you also want to use a serial monitor to see debug output then you could connect an FTDI to D4.

Pete.

1 Like

#20

WEMOS D1 mini TX is GPIO1
&
WEMOS D1 mini RX is GPIO3


I suggest to use Tasmota to check if your Board is OK (easiest solution)
or
use NodeMCU V3

Code : Is HERE

1 Like