BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Port forwarding with D-Link DIR-615

#1

Hi All,
I am using local blynk server and that is working perfectly fine with my local IP 192.168.0.108 and port 9443 But when I am trying to forward the port I am not able to connect to my local blynk server with my external public IP and port 9443.

I have used this URL(https://www.yougetsignal.com/tools/open-ports/) to check if port 9443 is open then it shows it is closed. Even port 80 is closed it says. Please help.

0 Likes

#2

Hello,

This is the Blynk forum, not the general networking forum :stuck_out_tongue: First off it appears you are setting up the Virtual Server, not Port Forwarding (they are different on my router)… for that Google is your friend…

https://www.google.com/search?q=D-Link+DIR-615+port+forwarding

0 Likes

#3

Hello !

@Gunner I know not a blynk related issue!
But even i tried on two different routers [Tplink and Dlink] but both mention them as virtual server and under them there is port forwarding settings. I am not understanding this is the way to go. I guess it would be great if someone does a documentation on Blynk local sever port forwarding (tutorial) . Have you ever tried and got results ? If so can you help us out ?

Thank you in advance.

0 Likes

#4

That’s not really practical, as it varies enormously from router to router, and also from one router firmware release to another.
If you take a look at this website:
https://portforward.com/router.htm

you’ll find step by step guides for thousands of different routers from hundreds of different manufacturers. I’m not sure what a Blynk tutorial could add to what’s already provided in this resource.

If you’re having problems with port forwarding it may be that your ISP is using a Double NAT system, which can make it impossible to achieve the result you want.
There is more info in this thread, although the information you need is scattered around and you need to study what is being said from post 16 onwards:

If the traceroute results show that your ISP uses Double NAT then you’ll need to talk to them about providing a dedicated (preferably static) external IP address.

Pete.

4 Likes

#5

Hi Pete,

Thank you for your valuable response. It seems that my local internet provider used double NAT system as my WAN IP and Public IP address are different.

0 Likes

#6

Hello,

So you can ask your ISP about ways to obtain public IP, or use service like VPS. Glad the theread above helped you!
Also thanks to Pete as always!
If you need further help, just reply or mention @Msprg.

Happy blinking!

2 Likes