Pi Local Server Questions

I am now trying to create a Local Server for a Pi Zero W, but am using a Pi 3B and Win10 laptop for configuring it. Last night I installed Raspbian with etcher, then loaded the card to the Pi3b and connected my monitor and keyboard and logged in just fine. I opened the console, downloaded/Installed (d/i) Java, d/i Blynk server and successfully made it through that process just fine. However, when attempting any of the commands to enable Restart, I am unable to edit the Local.RC file in the etc/ folder. I am also not able to log into my Blynk accounts via the browser for some reason. It seems the @ and " keys are switched, so possibly other keys in my password are switched as well?

I guess really what I need to know is do I need to configure the Raspbian and Blynk server files on my Windows machine before etching them to the SD card? I’m just trying to follow any tutorial to get a local server up, but it seems I keep finding the potholes in the road. Can anyone provide some insight?


Sounds like a regional issue… make sure you have setup the correct regions and KB for your area.

I don’t know if this link ever came to a solid resolution, but this is what you are running into:


I don’t think you can, as they reside on the unreadable partition the SD card (at least on the Windows PC). Just fix the KG settings and you will be good to go.

Burn the base image following the tutorials. I always use Debian which seems to be most stable. I haven’t had any problems with it for years now. Do invest in a decent SD card though. That seems to make a lot of difference. Any questions regarding setup, shoot away. Your willingness to invest time and brainmatter can count on a little support from my end.

And it’s just a lot more stable.

I have 2 of these discs, though IDK what constitutes as “good”. I’m only planning to use the Pi to serve the project, so I think I’ll probably use the Zero W and keep the Pi3b for Octoprint and other device control. I already launched the server from the Pi3, but I can’t do anything after that. I’m then unable to log into my app on my phone, I can’t edit the rc.local file when using the pi nor can I log into the UI from either my phone or the Pi itself. I’d like to be able to build the server.properties and mail.properties files as well as the Start, Stop and Restart scripts and whatever else would be need for the server to activate itself when inside the PiZero W because I don’t have a means of connecting to it otherwise, so if need be, I need instruction regarding that as well.


There are more ways to Rome. You could find a script on the forum here (there are a couple) for starting/stopping/updating/restarting. I myself wrote two which shouldn’t be too hard to find.

My .sh script can be added to init.d fairly easy (google for init.d startup script debian). The update script is a seperate script loosely working in conjunction with it. E.g. it checks for a new version, downloads it and restarts your server.

How do you start your server now? Can you show us a screenshot of how that works? We’ll go from there :slight_smile:

Sadly, I don’t know how to snap screen shots while inside of Raspbian, nor how to retrieve them from Pi. I’ve tried logging into either of my Blynk accounts from the Pi’s browser, but both return an invalid account. I can search of course and read threads/posts from inside of Pi, but that’s about it.

To launch the server, it seems that I need to reinstall Java 8, then load the jar file as described in the Blynk Server instructions on github. I thought the server would auto launch upon startup, but I was wrong.

If you are connecting to the Pi over VNC you can simply use the snipping tool in Windows…

To catch your RPi screenshots…

After I launched the server on the pi, I tried to connect via the Windows web browser ( and the teal Blynk screen appeared, but my login credentials weren’t being recognized so I was unable to connect to the Pi server from my Windows machine.

Edit - @Lichtsignaal, I SEARCHED for your init.d Startup script, but too many results were produced and I don’t know which one is yours. Can you link me to one of yours so I don’t look into using the wrong one?

That will just get you into the Server admin… nothing on the RPi desktop.

But the default credentials for the admin page have to be used first, then you can create your own…

1 Like

Thanks @Gunner, it let me advance one more step, but still looks to be short of full access. How should I proceed?

I know some Linux purists might break out the pitchforks :stuck_out_tongue: … but i just use this simple command in my /etc/rc.local file… obvoisly you would need to adjust for your folder and java version names :wink:

I tried last night to add a line of script to that file while in the Pi as instructed in the Blynk_Server/Github, but wasn’t able to save the file. I’m hoping I’ll be able to edit it (and other Linux settings) from Windows, albeit from the HTTPS connection, or directly on Windows and then etch the finished linux distro onto the micro SD card fully customized/optimized.

How do you access the Pi? via it’s own KB/mouse/monitor or via VNC from your PC?

I have my PC connected to a TV and a mouse/keyboard connected via a USB nub. I pull the HDMI and nub from the PC, plug them into the Pi3, then power it up and Rasbian displays on the TV. I launch the server from console, then unplug the HDMI and USB nub and reconnect those to the PC. I then open Firefox and open a new tab and enter the Server’s IP and the rest you already know.

Ouch :stuck_out_tongue:

OK, install VNC viewer on your PC and enable VNC on the Pi (if you can)…


I installed VNC on both PC and Pi and enabled the VNC on the Pi as you have pictured. I went back to the PC app and nothing changed. What am I supposed to do now?

What is “the PC App”? Blynk App on an android emulator?

RealVNC installed onto Windows PC, and also on the Rpi

Oh… OK, just start the VNC program and create a new connection (AKA a VNC server - the one on your RPi) , enter in the local IP of your RPi and it should connect and ask for your RPi username and password… and if all works, you will see a virtual window of your RPi desktop.

For reasons I cannot comprehend, I am not able to launch VNC from the Pi. I downloaded and installed it twice, but once complete, it just does nothing. I tried searching around the few icons on top/left, but found nothing regarding a VNC app that I can launch. That being said, I am not able to see anything to connect to from inside the PC/VNC app. To make it more of a PITA, I need to keep switching the USB and HDMI back to the PC just to reply because I am not able to log into Blynk from the Pi. I’m nearing the point where I wish to abandon trying to establish the server on the Pi via Raspian which I now believe is actually debian. Either case, IDK. Maybe I’m not meant to have a Blynk server as I’m trying to launch one from either Windows or Rpi and am hitting brick wall after brick wall on both fronts. It’s frustrating to say the least. Thank you for your time and efforts.