New nodemcu keeps "Connecting to"

new nodemcu keeps “Connecting to” cant figure it out using v0.4.4

Please update to latest Blynk libraries.

i thought 0.4.4. is the newest libraries?

It is. Please try to remove and download/unpack again. Seems like you either have old lib or hardcoded old host somewhere. As this host is no longer used (for 10 months already :slight_smile:)

checked installed version and it was 0.4.3 cant figure out how to install 0.4.4

i even used another computer that never had arduino ide on it

downloaded arduino ide downloaded blynk 0.4.4. added blynk to sketchbook location

went to manage libraries typed blynk still only shows vesion 0.4.3. and lower

Did you try manually downloading, unpacking and copying into your libraries folder.

yes… manager still only shows 4.3

Then something is corrupted in your Arduino install (or you are not grabbing the correct library from the link I sent)… because even 0.4.3 is new enough to not cause your connection issue.

Also, perhaps show us the (correctly formatted) code you are running on your nodemcu.

#define BLYNK_PRINT Serial    // Comment this out to disable prints and save space
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "YourAuthToken";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "YourNetworkName";
char pass[] = "YourPassword";

void setup()
  Blynk.begin(auth, ssid, pass);

void loop()

Please format the code (as per the link I sent) so we can see all the included libraries.

Ahh… I see you are trying :slight_smile: use this key three times before and after the code:

1 Like

got it

1 Like

the posting of code that is…

1 Like

I wouldn’t advise using the Library Manager until Blynk officially announces that it works.
Install the SIX libraries manually as per the release notes. Tools installation is optional.

will it show that 4.4 is installed in the library manager?

Take another look at my post… manually installing the libraries WILL show it…

so unzip and add the 6 separate folders to libraries or the entire 4.4 folder?

As he said :wink:

1 Like

its working! I figured it out last night, noticed my pic of the library manager did not have “Blynkesp8266_Lib”…
was able to manually install, still can not get 4.4 to install lol… but works great super responsive.

also why doesn’t blynk have a web based along with the app like cayenne… i would be using cayenne but cant get it to connect just shows gibberish on the serial monitor…